summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Haugh2018-02-03 17:02:36 -0600
committerSean Haugh2018-02-03 17:07:32 -0600
commit7fd18bc1e43a27dc9fda87630929b0f2ec819cd2 (patch)
tree0ee652e9223cf858805f98837244723aa6c0ee76
parent2db2d9c83ba81c669610ecb9434cb5167a8cd187 (diff)
downloadaur-7fd18bc1e43a27dc9fda87630929b0f2ec819cd2.tar.gz
Add conflict for exodus
Upstream deleted the exodus-bundler entry point.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab8c01305a75..6e6e498a9b21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = exodus-bundler
pkgdesc = Painless relocation of Linux binaries
pkgver = 1.1.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Intoli/exodus
arch = any
license = BSD
depends = python
depends = python-setuptools
- provides = exodus-bundler=1.1.5-1
+ provides = exodus-bundler=1.1.5-2
+ conflicts = exodus
source = https://github.com/Intoli/exodus/archive/v1.1.5.tar.gz
md5sums = fc29f5377753e1ad4abb1a4161c82024
diff --git a/PKGBUILD b/PKGBUILD
index e29500d69cee..123721515fe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@ _pkgname=exodus
_owner=Intoli
pkgname=exodus-bundler
pkgver=1.1.5
-pkgrel=1
+pkgrel=2
pkgdesc="Painless relocation of Linux binaries"
arch=('any')
url="https://github.com/$_owner/$_pkgname"
license=('BSD')
depends=('python' 'python-setuptools')
provides=("$pkgname=$pkgver-$pkgrel")
+conflicts=('exodus')
source=("https://github.com/$_owner/$_pkgname/archive/v$pkgver.tar.gz")
md5sums=('fc29f5377753e1ad4abb1a4161c82024')
@@ -19,8 +20,5 @@ package() {
install -Dm644 "$srcdir/$_pkgname-$pkgver/LICENSE.md" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- # XXX: Conflicts with exodus, the blockchain management app.
- msg "Removing /usr/bin/exodus for compatibility..."
- rm -v "$pkgdir/usr/bin/exodus"
}
# vim:set ts=2 sw=2 et: