summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Haugh2018-02-01 16:27:44 -0600
committerSean Haugh2018-02-01 16:27:44 -0600
commited862fcac5220cb160b57ae0dc4187e7a2b295a5 (patch)
tree209220303bedde3dc27790aa04aba40729b1419c
downloadaur-ed862fcac5220cb160b57ae0dc4187e7a2b295a5.tar.gz
nil → 1.1.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71dda62a74e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = exodus-bundler
+ pkgdesc = Painless relocation of Linux binaries
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/Intoli/exodus
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-setuptools
+ provides = exodus-bundler=1.1.2-1
+ source = https://github.com/Intoli/exodus/archive/v1.1.2.tar.gz
+ md5sums = 31e3ad8f9e8e9cbb9e82ea21d532c0fb
+
+pkgname = exodus-bundler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d92578cf59de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sean Haugh <seanphaugh@gmail.com>
+_pkgname=exodus
+_owner=Intoli
+pkgname=exodus-bundler
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Painless relocation of Linux binaries"
+arch=('any')
+url="https://github.com/$_owner/$_pkgname"
+license=('BSD')
+depends=('python' 'python-setuptools')
+provides=("$pkgname=$pkgver-$pkgrel")
+source=("https://github.com/$_owner/$_pkgname/archive/v$pkgver.tar.gz")
+md5sums=('31e3ad8f9e8e9cbb9e82ea21d532c0fb')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ install -Dm644 "$srcdir/$_pkgname-$pkgver/LICENSE.md" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # XXX: Conflicts with exodus, the blockchain management app.
+ msg "Removing /usr/bin/exodus for compatibility..."
+ rm -v "$pkgdir/usr/bin/exodus"
+}
+# vim:set ts=2 sw=2 et: