summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Sauter2023-08-21 12:23:35 +0200
committerPhilipp Sauter2023-08-21 12:50:43 +0200
commitd7d493e857867714527703cf06bc9102738d272d (patch)
treedc14364affbedd1bdf3858dde83191fefa44f431
parent0e94e0af450cdb7b8de82126ca30b1a47ac36fdb (diff)
downloadaur-d7d493e857867714527703cf06bc9102738d272d.tar.gz
build from source code in git repository
To comply with the AUR guidelines we build this package from the source code on GitHub instead of installing the binaries from the release tarball. An AUR package installing the prebuilt binaries will be made available as exoscale-cli-bin. This commit corresponds to release 1.72.0.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD35
2 files changed, 35 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16ba69a9ce12..47b1a17c0d62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,12 @@ pkgbase = exoscale-cli
url = https://github.com/exoscale/cli
arch = x86_64
license = Apache
- source = https://github.com/exoscale/cli/releases/download/v1.72.0/exoscale-cli_1.72.0_linux_amd64.tar.gz
- sha256sums = 816fcf0fa1c8acffa0bb557317a7f67f2657241783a20fcebcea408794f884c2
+ makedepends = git
+ makedepends = go
+ makedepends = make
+ source = exoscale-cli::git+https://github.com/exoscale/cli.git#tag=v1.72.0
+ source = git+https://github.com/exoscale/go.mk.git
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = exoscale-cli
diff --git a/PKGBUILD b/PKGBUILD
index 24dc2374b4fd..ee994acbb0a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Pierre-Yves Ritschard <pyr@spootnik.org>
+# Contributor: FabioLolix
pkgname=exoscale-cli
pkgver=1.72.0
@@ -8,14 +9,34 @@ arch=('x86_64')
url="https://github.com/exoscale/cli"
license=('Apache')
-source=("https://github.com/exoscale/cli/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_amd64.tar.gz")
+makedepends=(git go make)
+source=("${pkgname}::git+https://github.com/exoscale/cli.git#tag=v${pkgver}"
+ "git+https://github.com/exoscale/go.mk.git")
+sha256sums=('SKIP'
+ 'SKIP')
-sha256sums=('816fcf0fa1c8acffa0bb557317a7f67f2657241783a20fcebcea408794f884c2')
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ git submodule init
+ git config submodule.libs/libdep.url "$srcdir/lib-dependency"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ make build
+ make completions
+ make manpages
+}
package() {
- install -Dm755 "${srcdir}/exo" "${pkgdir}/usr/bin/exo"
- install -d 755 "${pkgdir}/usr/share/bash-completion/completions"
- install -Dm 644 "${srcdir}/contrib/completion/bash/exo" "${pkgdir}/usr/share/bash-completion/completions/exo"
- install -d 755 "${pkgdir}/usr/share/man/man1"
- install -Dm 644 "${srcdir}/manpage/"* "${pkgdir}/usr/share/man/man1"
+ cd "${srcdir}/${pkgname}"
+
+ install -Dm 755 ./bin/exo "${pkgdir}/usr/bin/exo"
+ install -Dm 644 ./contrib/completion/bash/exo -t "${pkgdir}/usr/share/bash-completion/completions/"
+ install -Dm 644 ./contrib/completion/zsh/_exo -t "${pkgdir}/usr/share/zsh/site-functions/"
+ install -dm 755 "${pkgdir}/usr/share/man/man1"
+ install -Dm 644 ./manpage/* "${pkgdir}/usr/share/man/man1"
}