summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Sauter2023-10-12 11:50:19 +0200
committerPhilipp Sauter2023-10-12 12:04:56 +0200
commitc0157b37d21bf938d6a1a97632a8790cd3ff6e99 (patch)
tree92810230695333fa2a009b55279756065b805a15
parent4ff7c3c83f280813296d051f58eee812cf144652 (diff)
downloadaur-c0157b37d21bf938d6a1a97632a8790cd3ff6e99.tar.gz
check whether the Exoscale Tooling key is available
-rw-r--r--PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 860cc097809f..12fce65f5165 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,17 @@ source=("https://github.com/exoscale/cli/releases/download/v${pkgver}/exoscale-c
sha256sums=('746a3fb2bbb29d104e2e61bf3cd194d85d02f808f8dfb7d80bebb75cebec47de'
'SKIP')
+if [ $SKIPPGPCHECK = 0 ] && ! gpg --list-keys 7100E8BFD6199CE0374CB7F003686F8CDE378D41 >/dev/null 2>&1; then
+ warning "This package is signed with a GPG key that is not on your system."
+ warning "To install this package, you either need to import the key:"
+ warning ""
+ warning " gpg --keyserver keys.openpgp.org --recv-key 7100E8BFD6199CE0374CB7F003686F8CDE378D41"
+ warning ""
+ warning "Or you may install the package without checking the signature:"
+ warning ""
+ warning " makepkg --skippgpcheck"
+fi
+
package() {
install -Dm755 "${srcdir}/exo" "${pkgdir}/usr/bin/exo"
install -d 755 "${pkgdir}/usr/share/bash-completion/completions"