summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Sauter2023-08-21 19:16:48 +0200
committerPhilipp Sauter2023-08-21 19:16:48 +0200
commitdc07b5b984ef4e08b47a2cd4a4bd90b2e63da333 (patch)
tree3f2c061e3c74b04b38007e4482b161641c30d319
downloadaur-dc07b5b984ef4e08b47a2cd4a4bd90b2e63da333.tar.gz
release 1.72.0.r2.g920ccbdc
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD58
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ae43142ae25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = exoscale-cli-git
+ pkgdesc = Command-line tool for everything at Exoscale: compute, storage, dns
+ pkgver = 1.72.0.r2.g920ccbdc
+ pkgrel = 1
+ url = https://github.com/exoscale/cli
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = go
+ makedepends = make
+ provides = exoscale-cli
+ conflicts = exoscale-cli
+ source = exoscale-cli-git::git+https://github.com/exoscale/cli.git
+ source = git+https://github.com/exoscale/go.mk.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = exoscale-cli-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74e9d7666254
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Pierre-Yves Ritschard <pyr@spootnik.org>
+# Contributor: FabioLolix
+
+pkgname=exoscale-cli-git
+pkgver=1.72.0.r2.g920ccbdc
+pkgrel=1
+pkgdesc="Command-line tool for everything at Exoscale: compute, storage, dns"
+arch=('x86_64')
+url="https://github.com/exoscale/cli"
+license=('Apache')
+provides=('exoscale-cli')
+conflicts=('exoscale-cli')
+
+makedepends=(git go make)
+source=("${pkgname}::git+https://github.com/exoscale/cli.git"
+ "git+https://github.com/exoscale/go.mk.git")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ git submodule init
+ git config submodule.libs/libdep.url "$srcdir/lib-dependency"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ # This package builds the latest commit on the master branch,
+ # which may be ahead of the latest release. But `make build`
+ # will bake the latest tag into the binary which is not accurate.
+ # Thus we set a temporary tag, so that the `exo version` command doesn't mislead.
+ git tag v${pkgver}
+
+ make build
+ make completions
+ make manpages
+
+ # cleanup the tag as it is not an official release
+ git tag -d v${pkgver}
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -Dm 755 ./bin/exo "${pkgdir}/usr/bin/exo"
+ install -Dm 644 ./contrib/completion/bash/exo -t "${pkgdir}/usr/share/bash-completion/completions/"
+ install -Dm 644 ./contrib/completion/zsh/_exo -t "${pkgdir}/usr/share/zsh/site-functions/"
+ install -dm 755 "${pkgdir}/usr/share/man/man1"
+ install -Dm 644 ./manpage/* "${pkgdir}/usr/share/man/man1"
+}