summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeth Murphy2019-04-24 12:44:17 -0400
committerSeth Murphy2019-04-24 12:44:17 -0400
commitd14abe047da72c9f2b704b3ea13a3fc4a9c0bd40 (patch)
treef7423f6ba56108c87717ad4d1e38e875eafae27b
parent7149793a25719672f87c8e3dab143ebe6fe9db4e (diff)
downloadaur-d14abe047da72c9f2b704b3ea13a3fc4a9c0bd40.tar.gz
Updated expandrive-bin to version 7.0.8
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD58
3 files changed, 53 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af363fbad432..b97b4ebc3b1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = expandrive-bin
pkgdesc = A utility for managing multiple cloud storage services
- pkgver = 7.0.5
+ pkgver = 7.0.8
pkgrel = 1
url = https://www.expandrive.com/
arch = x86_64
license = custom:proprietary
- depends = gconf>=2
- depends = libnotify
- depends = libappindicator-gtk3
- depends = libxtst
+ depends = fuse2
+ depends = gtk3
depends = nss
depends = libxss
- source = https://packages.expandrive.com/pool/stable/e/ex/ExpanDrive_7.0.5_amd64.deb
- sha256sums = 7676526f6655605a3c0774a639b154d865678e8e7b07d889e16bc080e7bd632b
+ source = LICENSE
+ source = https://packages.expandrive.com/pool/stable/e/ex/ExpanDrive_7.0.8_amd64.deb
+ sha256sums = dd77a86c9319a5e12b066688a0c804f942fd358b096ad1981eba04426dd16781
+ sha256sums = 17aab387629ebe365d8352d12a04c2926fdaaf7ba65be125f8994590899d7c47
pkgname = expandrive-bin
diff --git a/.gitignore b/.gitignore
index 70ceaf6af371..eb97197bfc72 100644
--- a/.gitignore
+++ b/.gitignore
@@ -50,3 +50,9 @@ src/
# Ignore any deb file that gets downloaded (for testing)
*.deb*
+
+# Ignore build directory. This is just some utilities I use when pushing changes
+build/
+
+# Ignore .vscode
+.vscode
diff --git a/PKGBUILD b/PKGBUILD
index 05f710f5a086..1ec77a0506a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,56 @@
# Maintainer: Seth Murphy <seth.murphy18@gmail.com>
# PGP ID: 1DB95DC235C2C613
-pkgname="expandrive-bin"
-pkgver="7.0.5"
-pkgrel="1"
-pkgdesc="A utility for managing multiple cloud storage services"
-arch=("x86_64")
-url="https://www.expandrive.com/"
-license=("custom:proprietary")
+pkgname='expandrive-bin'
+pkgver='7.0.8'
+pkgrel='1'
+pkgdesc='A utility for managing multiple cloud storage services'
+arch=('x86_64')
+url='https://www.expandrive.com/'
+license=('custom:proprietary')
depends=(
- "gconf>=2"
- "libnotify"
- "libappindicator-gtk3"
- "libxtst"
- "nss"
- "libxss"
+ 'fuse2'
+ 'gtk3'
+ 'nss'
+ 'libxss'
)
-source=("https://packages.expandrive.com/pool/stable/e/ex/ExpanDrive_${pkgver}_amd64.deb")
-sha256sums=("7676526f6655605a3c0774a639b154d865678e8e7b07d889e16bc080e7bd632b")
+source=('LICENSE'
+ "https://packages.expandrive.com/pool/stable/e/ex/ExpanDrive_${pkgver}_amd64.deb")
+sha256sums=('dd77a86c9319a5e12b066688a0c804f942fd358b096ad1981eba04426dd16781'
+ '17aab387629ebe365d8352d12a04c2926fdaaf7ba65be125f8994590899d7c47')
+
+prepare() {
+ # Create the package directory, if it doesn't already exist
+ if [ ! -d "$srcdir/data" ]; then
+ mkdir "$srcdir/data"
+ else
+ # If the directory exists, wipe its contents
+ rm -rf "$srcdir/data"
+ mkdir "$srcdir/data"
+ fi
+
+ tar -xf "$srcdir/data.tar.xz" -C "$srcdir/data"
+
+ # Remove unnecessary files from the package
+ rm -rf "$srcdir/data/opt/ExpanDrive/resources/app.asar.unpacked"
+}
package() {
- tar -xf data.tar.xz -C "${pkgdir}"
+ # Copy the source files to the package directory
+ cp -R "$srcdir/data/opt/" "$pkgdir/opt/"
+ cp -R "$srcdir/data/usr/" "$pkgdir/usr/"
+
+ # Install the LICENSE file in the correct place
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
post_install() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Link the ExpanDrive binary to /usr/local/bin
ln -sf '/opt/ExpanDrive/expandrive' '/usr/local/bin/expandrive'
}
-post_remove() {
+pre_remove() {
+ # Remove ExpanDrive from /usr/local/bin
rm -f '/usr/local/bin/expandrive'
} \ No newline at end of file