summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-10-07 13:31:46 +0800
committerChocobo12020-10-07 13:31:46 +0800
commit0d7a6606309c187ea826a02a2547f254be577ea5 (patch)
tree4971d01cb2c3e7b858bcf30d387fb97df909a6d5
parentb951f121b2e8878e6adb8c0b24c412a489946489 (diff)
downloadaur-0d7a6606309c187ea826a02a2547f254be577ea5.tar.gz
upgpkg: expat-git 2.2.10.r5.g0d9b0812-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD28
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d039ff80113..d3245dba866a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = expat-git
pkgdesc = A stream-oriented XML parser library written in C
- pkgver = 2.2.3.r39.g2cb09ae
+ pkgver = 2.2.10.r5.g0d9b0812
pkgrel = 1
url = https://libexpat.github.io/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 0d533da70333..db4dd124a1d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=expat-git
-pkgver=2.2.3.r39.g2cb09ae
+pkgver=2.2.10.r5.g0d9b0812
pkgrel=1
pkgdesc="A stream-oriented XML parser library written in C"
arch=('i686' 'x86_64')
@@ -15,12 +15,6 @@ source=("git+https://github.com/libexpat/libexpat.git")
sha256sums=('SKIP')
-prepare() {
- cd "libexpat/expat"
-
- mkdir -p "_build"
-}
-
pkgver() {
cd "libexpat/expat"
@@ -28,21 +22,25 @@ pkgver() {
}
build() {
- cd "libexpat/expat/_build"
+ cd "libexpat/expat"
- cmake -DCMAKE_INSTALL_PREFIX="/usr" ../
- make
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ ./
+ make -C "_build"
}
check() {
- cd "libexpat/expat/_build"
+ cd "libexpat/expat"
- make test
+ make -C "_build" test
}
package() {
- cd "libexpat/expat/_build"
+ cd "libexpat/expat"
- make DESTDIR="$pkgdir" install
- install -Dm644 "../COPYING" "$pkgdir/usr/share/licenses/expat/COPYING"
+ make -C "_build" DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/expat"
}