summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Vries2018-06-27 17:23:08 +0200
committerMaarten de Vries2018-06-27 17:23:08 +0200
commit5181c13e6bc946bfc32ae36d1ec623a2cfa7e210 (patch)
tree500526cc1d139f672b53361eb9485b77def77b54
downloadaur-5181c13e6bc946bfc32ae36d1ec623a2cfa7e210.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
-rw-r--r--expat-1.95.8-destdir.patch37
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b094880b691
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = expat1
+ pkgdesc = An XML parser library
+ pkgver = 1.95.8
+ pkgrel = 1
+ url = https://libexpat.github.io/
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = https://github.com/libexpat/libexpat/releases/download/R_1_95_8/expat-1.95.8.tar.gz
+ source = expat-1.95.8-destdir.patch
+ sha256sums = c6aaa0b427e775a0fd5a956a75ae41e5110f22760723d9bda316100010e891ca
+ sha256sums = bd61f7b436c2a3e42bc77f896b56a5cfda7f7127e93795ee312dc0056a502958
+
+pkgname = expat1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..584d20bd5da1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Maarten de Vries <maarten@de-vri.es>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=expat1
+_name=expat
+pkgver=1.95.8
+pkgrel=1
+pkgdesc='An XML parser library'
+arch=(x86_64)
+url='https://libexpat.github.io/'
+license=(custom)
+depends=(glibc)
+
+source=(
+ "https://github.com/libexpat/libexpat/releases/download/R_1_95_8/expat-1.95.8.tar.gz"
+ "expat-1.95.8-destdir.patch"
+)
+sha256sums=('c6aaa0b427e775a0fd5a956a75ae41e5110f22760723d9bda316100010e891ca'
+ 'bd61f7b436c2a3e42bc77f896b56a5cfda7f7127e93795ee312dc0056a502958')
+
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+ patch -p1 < "$srcdir/expat-1.95.8-destdir.patch"
+ ./configure --prefix=/usr --disable-static
+}
+
+build() {
+ cd $_name-$pkgver
+ make
+}
+
+check() {
+ make -C $_name-$pkgver check
+}
+
+package() {
+ cd $_name-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "-t$pkgdir/usr/share/licenses/$pkgname" COPYING
+ rm "$pkgdir/usr/lib/libexpat.so"
+ rm -rf "$pkgdir/usr/bin"
+ rm -rf "$pkgdir/usr/include"
+ rm -rf "$pkgdir/usr/man"
+}
diff --git a/expat-1.95.8-destdir.patch b/expat-1.95.8-destdir.patch
new file mode 100644
index 000000000000..1a625339ada2
--- /dev/null
+++ b/expat-1.95.8-destdir.patch
@@ -0,0 +1,37 @@
+diff --git a/Makefile.in b/Makefile.in
+index 89c695a..5ef3384 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -73,22 +73,22 @@ check: tests/runtests
+ tests/runtests
+
+ install: xmlwf/xmlwf installlib
+- $(mkinstalldirs) $(bindir) $(man1dir)
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(bindir)/xmlwf
+- $(INSTALL_DATA) $(MANFILE) $(man1dir)
++ $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
++ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(DESTDIR)$(bindir)/xmlwf
++ $(INSTALL_DATA) $(MANFILE) $(DESTDIR)$(man1dir)
+
+ installlib: $(LIBRARY) $(APIHEADER)
+- $(mkinstalldirs) $(libdir) $(includedir)
+- $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(libdir)/$(LIBRARY)
+- $(INSTALL_DATA) $(APIHEADER) $(includedir)
++ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
++ $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(DESTDIR)$(libdir)/$(LIBRARY)
++ $(INSTALL_DATA) $(APIHEADER) $(DESTDIR)$(includedir)
+
+ uninstall: uninstalllib
+- $(LIBTOOL) --mode=uninstall rm -f $(bindir)/xmlwf
+- rm -f $(man1dir)/xmlwf.1
++ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(bindir)/xmlwf
++ rm -f $(DESTDIR)$(man1dir)/xmlwf.1
+
+ uninstalllib:
+- $(LIBTOOL) --mode=uninstall rm -f $(libdir)/$(LIBRARY)
+- rm -f $(includedir)/$(APIHEADER)
++ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(libdir)/$(LIBRARY)
++ rm -f $(DESTDIR)$(includedir)/$(APIHEADER)
+
+ # for VPATH builds (invoked by configure)
+ mkdir-init: