summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Kugland2021-08-25 05:52:44 -0300
committerAndré Kugland2021-08-25 05:52:44 -0300
commit7eb4df49487b9e62e26080afa5a72b5b020a8385 (patch)
tree28656a1542ff35ca9254ee0edea5b52f4f72348e
downloadaur-7eb4df49487b9e62e26080afa5a72b5b020a8385.tar.gz
first commit
Signed-off-by: André Kugland <kugland@gmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9788c11c9417
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = create-react-native-app
+ pkgdesc = The fastest way to create universal React Native apps
+ pkgver = 3.6.0
+ pkgrel = 1
+ url = https://github.com/expo/create-react-native-app
+ arch = any
+ license = BSD-3-Clause
+ makedepends = npm
+ depends = nodejs
+ options = !emptydirs
+
+pkgname = create-react-native-app
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5fb31edeb46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: André Kugland <kugland@gmail.com>
+pkgname=create-react-native-app
+pkgver=3.6.0
+pkgrel=1
+pkgdesc="The fastest way to create universal React Native apps"
+arch=(any)
+url="https://github.com/expo/create-react-native-app"
+license=('BSD-3-Clause')
+depends=('nodejs')
+makedepends=('npm')
+options=('!emptydirs')
+
+package() {
+ npm install -g --prefix "$pkgdir/usr" --cache "$srcdir/npm-cache" $pkgname@$pkgver
+ find "$pkgdir/usr" -type d -exec chmod 755 {} +
+}