summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2018-02-27 17:15:58 -0800
committerFabio Zanini2018-02-27 17:15:58 -0800
commita86e71c69a6c1a63644bd1560726330413fcd274 (patch)
tree627064e7652c1c12048ec3e9eb519d2931dbc3bf
downloadaur-a86e71c69a6c1a63644bd1560726330413fcd274.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d664ce2d90c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = expressionmatrix2-git
+ pkgdesc = Software for exploration of gene expression data from single-cell RNA sequencing.
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/chanzuckerberg/ExpressionMatrix2
+ arch = x86_64
+ license = MIT
+ depends = python
+ depends = python-numpy
+ depends = cmake
+ depends = make
+ depends = pybind11
+ source = expressionmatrix2-git::git+https://github.com/iosonofabio/ExpressionMatrix2.git#branch=master
+ md5sums = SKIP
+
+pkgname = expressionmatrix2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a66c6cfb3871
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Fabio Zanini <fabio.zanini __AT_ fastmail.fm>
+pkgname=expressionmatrix2-git
+pkgver=0.4
+pkgrel=1
+pkgdesc="Software for exploration of gene expression data from single-cell RNA sequencing."
+url="https://github.com/chanzuckerberg/ExpressionMatrix2"
+arch=('x86_64')
+license=("MIT")
+depends=('python' 'python-numpy' 'cmake' 'make' 'pybind11')
+# FIXME
+#source=("expressionmatrix2-git::git+https://github.com/chanzuckerberg/ExpressionMatrix2.git#branch=master")
+source=("expressionmatrix2-git::git+https://github.com/iosonofabio/ExpressionMatrix2.git#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ #cd "$pkgname"
+ #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ # NOTE: has no tags
+ echo '0.4'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ mkdir -p build
+ cd build
+ cmake -DPYTHON_INCLUDE_PATH=/usr/include/python3.6m -DPYBIND11_INCLUDE_PATH=/usr/include/pybind11 -DHDF5_INCLUDE_PATH=/usr/include -DHDF5_LIBRARIES="hdf5_cpp hdf5" ../src
+ make -j
+}
+
+package() {
+ cd "$srcdir/$pkgname/build"
+
+ mkdir -p "$pkgdir/usr/lib/python3.6/site-packages/"
+ install -m755 ExpressionMatrix2.so "$pkgdir/usr/lib/python3.6/site-packages/"
+}