summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-06-29 17:58:52 +0200
committerDaniel Peukert2024-06-29 17:58:52 +0200
commit8706dd662931aa5f0f9689e0146ecc7eee58acb4 (patch)
treecbde36a967adcf2dba74804e5a114a9fad817e22
parent4154c050908126c2ffd0f09831d09526d4b1b9c7 (diff)
downloadaur-8706dd662931aa5f0f9689e0146ecc7eee58acb4.tar.gz
Update expresslrs-configurator to 1.7.0 (closes #596)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--electron-builder-config.diff44
-rw-r--r--fix-i18n-location.diff13
-rw-r--r--fix-resource-locations.diff42
5 files changed, 87 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eaf41cd29504..afcfb31d9852 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = expresslrs-configurator
pkgdesc = Cross platform configuration & build tool for the ExpressLRS radio link
- pkgver = 1.6.1
+ pkgver = 1.7.0
pkgrel = 1
url = https://github.com/ExpressLRS/ExpressLRS-Configurator
arch = x86_64
@@ -11,17 +11,17 @@ pkgbase = expresslrs-configurator
makedepends = npm>=6.0.0
makedepends = libxcrypt-compat
makedepends = yarn>=1.21.3
- depends = electron20
+ depends = electron27
depends = platformio-core-udev
depends = python>=3.0.0
- source = expresslrs-configurator-1.6.1.tar.gz::https://github.com/ExpressLRS/ExpressLRS-Configurator/archive/v1.6.1.tar.gz
+ source = expresslrs-configurator-1.7.0.tar.gz::https://github.com/ExpressLRS/ExpressLRS-Configurator/archive/v1.7.0.tar.gz
source = electron-launcher.sh
- source = fix-i18n-location.diff
+ source = fix-resource-locations.diff
source = electron-builder-config.diff
- sha512sums = 814382992a22a8c59e9dfbade10bbba930ca9085161f4ca7bb6cb9828910f6cbc4299d9b4afb81fe42cdc4782489fa9bd324cab92e908839d2e6f1fadc64ab28
- sha512sums = c00d5973f4d9bb949edc498bd0a4577a394f6003b3337e12783a1febbb95579cfbda9fe53dc13a9ce5d029871b0c2bf95f30b0b95ae3116c684fa31f8779bfd1
- sha512sums = b234a14ed809004165dbecec399521eea9ede8186a46f9565dfae2b37e429c2e6f23ce208443896f02eb4ce81ba09cbfd4ce943298300a336bda4cd134d2aded
- sha512sums = 30576c2cc5e7c78e25090e6a00fa9a2d3fb91fc19b476f97104f6f7be3dc1851520e2596c4fb04d7eb284dc3866b373c83bf5715a8e0074453ed3ae270998513
+ b2sums = 199cf9d351b164ff3fe8a07396a479772c2a12de27475afbe32b18dac52295371a26abb55ffce0f00c29c3bb19af84a27cd2270049397272b25936d16a22fa22
+ b2sums = ac21805ec823b40ac925e1abec13edb8c4a3e5bbcfc65629b83e5923f4328dfccafb11c5c6895d8484cb730afce0a3977113d0d2266ba95d05216b4ea4077b4d
+ b2sums = 98ed125215ecc3a1a3e1dc52211cd65d713baad56573254ecb96ad6713f4f14c57f83ef97ff12f059d0058ce946e739e95d4a0ea9a07e3f60664547059ff1b3d
+ b2sums = fcf6859cdf2a2a71330b329add29328eb7a9075006383c627426ba43788ca4875f9108b8f1aa0da11f0bb6bb0d61a361aeb3f9666b69b54f7a2085fcf62640b5
depends_armv7h = lib32-gcc-libs
depends_armv7h = lib32-glibc
diff --git a/PKGBUILD b/PKGBUILD
index b5d4658122e2..0aef76a27964 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
# Contributor: Erik Moldtmann <erik@moldtmann.de>
_projectname='ExpressLRS-Configurator'
pkgname="${_projectname,,}"
-pkgver='1.6.1'
+pkgver='1.7.0'
pkgrel='1'
pkgdesc='Cross platform configuration & build tool for the ExpressLRS radio link'
-# If you're running on armv7h or aarch64, use the electron20-bin package from the AUR for the electron20 dependency
-# If you're running on armv7h, you have to add it to the arch and source arrays of the electron20-bin AUR dependency
+# If you're running on armv7h or aarch64, use the electron27-bin package from the AUR for the electron27 dependency
+# If you're running on armv7h, you have to add it to the arch and source arrays of the electron27-bin AUR dependency
arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/ExpressLRS/$_projectname"
license=('GPL-3.0-only')
-_electronpkg='electron20'
+_electronpkg='electron27'
depends=("$_electronpkg" 'platformio-core-udev' 'python>=3.0.0')
depends_armv7h=('lib32-gcc-libs' 'lib32-glibc')
makedepends=('nodejs>=16.0.0' 'npm>=6.0.0' 'libxcrypt-compat' 'yarn>=1.21.3')
source=(
"$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
'electron-launcher.sh'
- 'fix-i18n-location.diff'
+ 'fix-resource-locations.diff'
'electron-builder-config.diff'
)
-sha512sums=('814382992a22a8c59e9dfbade10bbba930ca9085161f4ca7bb6cb9828910f6cbc4299d9b4afb81fe42cdc4782489fa9bd324cab92e908839d2e6f1fadc64ab28'
- 'c00d5973f4d9bb949edc498bd0a4577a394f6003b3337e12783a1febbb95579cfbda9fe53dc13a9ce5d029871b0c2bf95f30b0b95ae3116c684fa31f8779bfd1'
- 'b234a14ed809004165dbecec399521eea9ede8186a46f9565dfae2b37e429c2e6f23ce208443896f02eb4ce81ba09cbfd4ce943298300a336bda4cd134d2aded'
- '30576c2cc5e7c78e25090e6a00fa9a2d3fb91fc19b476f97104f6f7be3dc1851520e2596c4fb04d7eb284dc3866b373c83bf5715a8e0074453ed3ae270998513')
+b2sums=('199cf9d351b164ff3fe8a07396a479772c2a12de27475afbe32b18dac52295371a26abb55ffce0f00c29c3bb19af84a27cd2270049397272b25936d16a22fa22'
+ 'ac21805ec823b40ac925e1abec13edb8c4a3e5bbcfc65629b83e5923f4328dfccafb11c5c6895d8484cb730afce0a3977113d0d2266ba95d05216b4ea4077b4d'
+ '98ed125215ecc3a1a3e1dc52211cd65d713baad56573254ecb96ad6713f4f14c57f83ef97ff12f059d0058ce946e739e95d4a0ea9a07e3f60664547059ff1b3d'
+ 'fcf6859cdf2a2a71330b329add29328eb7a9075006383c627426ba43788ca4875f9108b8f1aa0da11f0bb6bb0d61a361aeb3f9666b69b54f7a2085fcf62640b5')
_sourcedirectory="$_projectname-$pkgver"
@@ -36,8 +36,8 @@ prepare() {
# Disable husky, as it only works with a cloned repo
sed -i '/husky install/d' 'package.json'
- # Fix i18n directory location
- patch --forward -p1 < "$srcdir/fix-i18n-location.diff"
+ # Fix resource directory locations
+ patch --forward -p1 < "$srcdir/fix-resource-locations.diff"
# Set system Electron version for ABI compatibility
sed -E -i 's|("electron": ").*"|\1'"$(cat "/usr/lib/$_electronpkg/version")"'"|' 'package.json'
diff --git a/electron-builder-config.diff b/electron-builder-config.diff
index c05353eb44ea..6f94427a1e89 100644
--- a/electron-builder-config.diff
+++ b/electron-builder-config.diff
@@ -1,11 +1,11 @@
diff --git a/package.json b/package.json
-index 488a3136..f835ffe4 100644
+index 1844f3cc..f1b16209 100644
--- a/package.json
+++ b/package.json
-@@ -52,91 +52,27 @@
+@@ -54,99 +54,28 @@
"devices/"
],
- "afterSign": ".erb/scripts/Notarize.js",
+ "afterSign": ".erb/scripts/notarize.js",
- "mac": {
- "target": [
- "dmg"
@@ -65,21 +65,29 @@ index 488a3136..f835ffe4 100644
]
},
- "rpm": {
+- "executableArgs": [
+- "--no-sandbox"
+- ],
- "depends": [
- "git",
- "python3"
- ]
- },
"pacman": {
+- "executableArgs": [
+- "--no-sandbox"
+ "fpm": [
+ "--pacman-compression=none"
-+ ],
- "depends": [
- "git",
- "python3"
- ]
- },
+ ],
+- "depends": [
+- "git",
+- "python3"
+- ]
+- },
- "snap": {
+- "executableArgs": [
+- "--no-sandbox"
+- ],
- "stagePackages": [
- "default",
- "git",
@@ -87,17 +95,17 @@ index 488a3136..f835ffe4 100644
- ]
- },
- "deb": {
-- "depends": [
-- "git",
+ "executableArgs": [
+ "--no-sandbox"
+ ],
+ "depends": [
+ "git",
- "python3",
-- "python3-distutils",
-- "gconf2",
-- "gconf-service",
+- "python3-setuptools",
- "libnotify4",
- "libxtst6",
- "libnss3"
-- ]
-- },
++ "python3"
+ ]
+ },
"directories": {
- "app": "src",
- "buildResources": "assets",
diff --git a/fix-i18n-location.diff b/fix-i18n-location.diff
deleted file mode 100644
index 4a30a27ce53a..000000000000
--- a/fix-i18n-location.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/main.dev.ts b/src/main.dev.ts
-index a39fc2b5..0fedde7c 100644
---- a/src/main.dev.ts
-+++ b/src/main.dev.ts
-@@ -310,7 +310,7 @@ const createWindow = async () => {
-
- const localesPath = app.isPackaged
- ? path.join(process.resourcesPath, 'i18n', 'locales')
-- : path.join(__dirname, 'i18n', 'locales');
-+ : path.join(__dirname, '../i18n', 'locales');
-
- logger.log('localesPath', { localesPath });
-
diff --git a/fix-resource-locations.diff b/fix-resource-locations.diff
new file mode 100644
index 000000000000..1c368d1a8775
--- /dev/null
+++ b/fix-resource-locations.diff
@@ -0,0 +1,42 @@
+diff --git a/src/main/main.ts b/src/main/main.ts
+index 49ed99a0..83289649 100644
+--- a/src/main/main.ts
++++ b/src/main/main.ts
+@@ -206,9 +206,7 @@ const createWindow = async () => {
+ await installExtensions();
+ }
+
+- const RESOURCES_PATH = app.isPackaged
+- ? path.join(process.resourcesPath, 'assets')
+- : path.join(__dirname, '../../assets');
++ const RESOURCES_PATH = path.join(__dirname, '../../../assets');
+
+ const getAssetPath = (...paths: string[]): string => {
+ return path.join(RESOURCES_PATH, ...paths);
+@@ -238,9 +236,7 @@ const createWindow = async () => {
+ 'userDefines'
+ );
+
+- const dependenciesPath = app.isPackaged
+- ? path.join(process.resourcesPath, '../dependencies')
+- : path.join(__dirname, '../../dependencies');
++ const dependenciesPath = path.join(__dirname, '../../../dependencies');
+
+ const getPlatformioPath = path.join(dependenciesPath, 'get-platformio.py');
+ const platformioStateTempStoragePath = path.join(
+@@ -327,13 +323,9 @@ const createWindow = async () => {
+ }
+ localApiServerEnv.PATH = PATH;
+
+- const devicesPath = app.isPackaged
+- ? path.join(process.resourcesPath, 'devices')
+- : path.join(__dirname, '../../devices');
++ const devicesPath = path.join(__dirname, '../../../devices');
+
+- const localesPath = app.isPackaged
+- ? path.join(process.resourcesPath, 'i18n', 'locales')
+- : path.join(__dirname, '../', 'i18n', 'locales');
++ const localesPath = path.join(__dirname, '../../../', 'i18n', 'locales');
+
+ logger.log('localesPath', { localesPath });
+