summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Moldtmann2021-05-01 21:37:23 +0200
committerErik Moldtmann2021-05-01 21:37:23 +0200
commita379a76ea9e3cf4119b2d41b19f73b28317795b4 (patch)
treedd5b3a58c9deab1e8dfed2106413f79839c1a253
downloadaur-a379a76ea9e3cf4119b2d41b19f73b28317795b4.tar.gz
initial
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD40
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87c5568ce401
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = expresslrs-configurator
+ pkgdesc = Cross platform configuration & build tool for the ExpressLRS radio link
+ pkgver = 0.4.13
+ pkgrel = 1
+ url = https://github.com/ExpressLRS/ExpressLRS-Configurator
+ arch = x86_64
+ license = GPL
+ source = https://github.com/ExpressLRS/ExpressLRS-Configurator/releases/download/v0.4.13/expresslrs-configurator-0.4.13.pacman
+ md5sums = 206ba5250c40d539ad5f5b1feb0e7bcc
+
+pkgname = expresslrs-configurator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c94459876331
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Erik Moldtmann <erik@moldtmann.de>
+pkgname=expresslrs-configurator
+pkgver=0.4.13
+pkgrel=1
+epoch=
+pkgdesc="Cross platform configuration & build tool for the ExpressLRS radio link"
+arch=('x86_64')
+url="https://github.com/ExpressLRS/ExpressLRS-Configurator"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/ExpressLRS/ExpressLRS-Configurator/releases/download/v$pkgver/expresslrs-configurator-$pkgver.pacman")
+md5sums=('206ba5250c40d539ad5f5b1feb0e7bcc')
+noextract=()
+
+package() {
+ # Install the application files in /opt
+ install -d "${pkgdir}/opt"
+ cp -R "${srcdir}/opt/ExpressLRS Configurator" "${pkgdir}/opt/"
+ # Install the .desktop file
+ install -D -m644 "${srcdir}/usr/share/applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ # Install the icons
+ for icon_size in 16 24 32 48 64 96 128 256 512; do
+ icons_dir="/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps"
+ install -d "${pkgdir}/${icons_dir}"
+ install -m644 "${srcdir}${icons_dir}/${pkgname}.png" \
+ "${pkgdir}${icons_dir}/${pkgname}.png"
+ done
+
+}