summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2015-11-16 18:32:15 +0100
committerMichel Zou2015-11-16 18:32:15 +0100
commit3ec29e272089d4875985367fe50f5a3f6b764cc9 (patch)
treef97090cf981660f05c5e233d2a5df0bd80ff4d36
downloadaur-3ec29e272089d4875985367fe50f5a3f6b764cc9.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae5559d492ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = exprtk-git
+ pkgdesc = C++ Mathematical Expression Library
+ pkgver = r170.b8e8b95
+ pkgrel = 1
+ url = http://www.partow.net/programming/exprtk/index.html
+ arch = any
+ license = CPL
+ makedepends = git
+ provides = exprtk
+ conflicts = exprtk
+ source = git+https://github.com/ArashPartow/exprtk.git
+ md5sums = SKIP
+
+pkgname = exprtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80bac229c371
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=exprtk-git
+pkgver=r170.b8e8b95
+pkgrel=1
+pkgdesc="C++ Mathematical Expression Library"
+arch=('any')
+url="http://www.partow.net/programming/exprtk/index.html"
+license=('CPL')
+depends=()
+makedepends=('git')
+provides=('exprtk')
+conflicts=('exprtk')
+source=('git+https://github.com/ArashPartow/exprtk.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/exprtk"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/exprtk"
+ install -d "${pkgdir}"/usr/include
+ install -D -m644 exprtk.hpp "${pkgdir}"/usr/include
+}