summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbdo Roig-Maranges2018-07-14 21:59:46 +0200
committerAbdo Roig-Maranges2018-07-14 21:59:46 +0200
commitc52cb68441fca50744536a071bdff897b5ced06d (patch)
tree1b500e7ba601b70f7291f5647000dca27073de56
parent46fc2c5e0eb18b18982253570c691ccb42c2b4de (diff)
downloadaur-c52cb68441fca50744536a071bdff897b5ced06d.tar.gz
fix llvm build with new gcc
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--fix-llvm-build.patch19
3 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 166637b3d7af..63de982dc399 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = extempore-git
pkgdesc = A cyber-physical programming environment for live coding
- pkgver = 0.7.0.r388.g951540a0
+ pkgver = 0.7.0.r390.g853a442a
pkgrel = 1
url = http://extempore.moso.com.au
arch = i686
@@ -17,7 +17,9 @@ pkgbase = extempore-git
provides = extempore
conflicts = extempore
source = git+https://github.com/digego/extempore.git
- md5sums = SKIP
+ source = fix-llvm-build.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = extempore-git
diff --git a/PKGBUILD b/PKGBUILD
index cfa93584b7a6..7c184b5dd841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Abdó Roig-Maranges <abdo.roig@gmail.com>
pkgname=extempore-git
-pkgver=0.7.0.r388.g951540a0
+pkgver=0.7.0.r390.g853a442a
pkgrel=1
pkgdesc="A cyber-physical programming environment for live coding"
arch=('i686' 'x86_64')
@@ -12,8 +12,9 @@ makedepends=('git' 'cmake' 'gcc' 'perl')
optdepends=('jack')
provides=('extempore')
conflicts=('extempore')
-source=("git+https://github.com/digego/extempore.git")
-md5sums=('SKIP')
+source=("git+https://github.com/digego/extempore.git"
+ "fix-llvm-build.patch")
+sha256sums=('SKIP' 'SKIP')
pkgver() {
git --git-dir="${srcdir}/extempore/.git" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -21,10 +22,7 @@ pkgver() {
prepare() {
cd "${srcdir}/extempore"
-
- # Do not hook up aot_extended on ALL. Otherwise it is run at make install,
- # since it does not track build products.
- sed -i 's/aot_extended ALL/aot_extended/g' CMakeLists.txt
+ patch -p1 -i "${srcdir}/fix-llvm-build.patch"
}
build() {
@@ -49,7 +47,7 @@ package() {
# emacs and vim files
install -D "${srcdir}/extempore/extras/extempore.el" "${pkgdir}/usr/share/emacs/site-lisp/extempore/extempore.el"
- # NOTE: The vim file interferes with vim, overriding global bindins.
+ # NOTE: The vim file interferes with vim, overriding global bindings.
# install -D "${srcdir}/extempore/extras/extempore.vim" "${pkgdir}/usr/share/vim/vimfiles/plugin/extempore.vim"
install -d "${pkgdir}/usr/bin"
diff --git a/fix-llvm-build.patch b/fix-llvm-build.patch
new file mode 100644
index 000000000000..33caebd69b42
--- /dev/null
+++ b/fix-llvm-build.patch
@@ -0,0 +1,19 @@
+diff --git a/extras/extempore-llvm-3.8.0.patch b/extras/extempore-llvm-3.8.0.patch
+index 84a92d48..c543cbe4 100644
+--- a/extras/extempore-llvm-3.8.0.patch
++++ b/extras/extempore-llvm-3.8.0.patch
+@@ -35,3 +35,14 @@
+ break;
+ }
+ }
++--- include/llvm/IR/ValueMap.h 2015-08-04 00:30:24.000000000 +0200
+++++ include/llvm/IR/ValueMap.h 2018-07-14 21:09:09.769502736 +0200
++@@ -99,7 +99,7 @@
++ explicit ValueMap(const ExtraData &Data, unsigned NumInitBuckets = 64)
++ : Map(NumInitBuckets), Data(Data) {}
++
++- bool hasMD() const { return MDMap; }
+++ bool hasMD() const { return static_cast<bool>(MDMap); }
++ MDMapT &MD() {
++ if (!MDMap)
++ MDMap.reset(new MDMapT);