summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincenzo Castiglia2020-05-03 16:47:02 +0200
committerVincenzo Castiglia2020-05-03 16:47:02 +0200
commitee23ed4a0b61c8f21dc639e8ede503a80f0e96de (patch)
treef7a98c705ef7c395cd2d179deee20a3be632e2b7
parentaad863cfc17511179f8ff5c1e28b89c918b85826 (diff)
downloadaur-ee23ed4a0b61c8f21dc639e8ede503a80f0e96de.tar.gz
install in /opt/extempore-git instead of /opt ; fix assets build for upstream change ; assets on by default ; added comment for emacs mode
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f1fbc2b7fe1..2ae83e566dc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = extempore-git
pkgdesc = A cyber-physical programming environment for live coding
- pkgver = 0.7.0.r413.g2b15d64c
+ pkgver = v0.8.6.lens.r10.g794180ff
pkgrel = 1
url = http://extempore.moso.com.au
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index e5c74a165ba8..d482aa1e0ed3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Abdó Roig-Maranges <abdo.roig@gmail.com>
pkgname=extempore-git
-pkgver=0.7.0.r413.g2b15d64c
+pkgver=v0.8.6.lens.r10.g794180ff
pkgrel=1
pkgdesc="A cyber-physical programming environment for live coding"
arch=('i686' 'x86_64')
@@ -23,14 +23,15 @@ build() {
mkdir -p "${srcdir}/build"
cd "${srcdir}/build"
- cmake -DCMAKE_INSTALL_PREFIX=/opt \
- -DJACK=ON \
- -DBUILD_DEPS=ON \
- -DPACKAGE=ON \
+ # NOTE: set ASSETS to OFF you you don't want to download ~500MB of assets
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/${pkgname} \
+ -DJACK=ON \
+ -DBUILD_DEPS=ON \
+ -DPACKAGE=ON \
+ -DASSETS=ON \
../extempore
make
- make assets
}
package() {
@@ -38,14 +39,14 @@ package() {
make DESTDIR="${pkgdir}/" install
- # emacs and vim files
+ # NOTE: emacs extempore-mode was moved, left here because someone upgrading might get the message
install -D "${srcdir}/extempore/extras/extempore.el" "${pkgdir}/usr/share/emacs/site-lisp/extempore/extempore.el"
# NOTE: The vim file interferes with vim, overriding global bindings.
# install -D "${srcdir}/extempore/extras/extempore.vim" "${pkgdir}/usr/share/vim/vimfiles/plugin/extempore.vim"
install -d "${pkgdir}/usr/bin"
- ln -s /opt/extempore/extempore "${pkgdir}/usr/bin/extempore"
+ ln -s "/opt/${pkgname}/extempore" "${pkgdir}/usr/bin/extempore"
}