summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBill Sideris2024-05-18 01:20:59 +0300
committerBill Sideris2024-05-18 01:20:59 +0300
commit78ae0e6ed422f0ded64ca97b3295ed572337159c (patch)
tree5c84911c62cfb0ab0abac4ed13f201831fc0fc1c
parent8a078f44628739d07b45356979faea3b00b16a33 (diff)
downloadaur-78ae0e6ed422f0ded64ca97b3295ed572337159c.tar.gz
Add upstream packages and bump version. It now builds.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--osc1.patch15
-rw-r--r--osc2.patch15
4 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91c6800c04ac..09ce4d659448 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = extension-manager
pkgdesc = A native tool for browsing, installing, and managing GNOME Shell Extensions
pkgver = 0.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mjakeman/extension-manager
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 3962257fd50d..62b336653b32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=extension-manager
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A native tool for browsing, installing, and managing GNOME Shell Extensions"
arch=('x86_64' 'aarch64')
url="https://github.com/mjakeman/extension-manager"
@@ -11,14 +11,16 @@ depends=('libadwaita' 'libsoup3' 'json-glib' 'text-engine')
makedepends=('meson' 'blueprint-compiler' 'gobject-introspection')
checkdepends=('appstream-glib')
optdepends=('libbacktrace-git')
-source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz backtrace.patch return-ext.patch return-inst.patch index.patch)
-sha256sums=('b4cd95cbf45a3d046858fb44e78f3e3147a24279e77bfbbe8a422920f20a7b3b' 'b2adaa69092e6a58cc6b15574f6a68f94bad606922620a276ea3db80a4b74bed' 'bfe1d1731fb97ae5dfd29a37befdf45ba51216629eacdf11710252762acd7023' 'e0d68cc71b1513577db20a0d5fea04a15f980f86142228f5ee03ce1334642066' 'a8a583163d8988d3e241d8d03e62c68204ff8ca15706908f49df2a0590cb8e74')
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz backtrace.patch return-ext.patch return-inst.patch index.patch osc1.patch osc2.patch)
+sha256sums=('b4cd95cbf45a3d046858fb44e78f3e3147a24279e77bfbbe8a422920f20a7b3b' 'b2adaa69092e6a58cc6b15574f6a68f94bad606922620a276ea3db80a4b74bed' 'bfe1d1731fb97ae5dfd29a37befdf45ba51216629eacdf11710252762acd7023' 'e0d68cc71b1513577db20a0d5fea04a15f980f86142228f5ee03ce1334642066' 'a8a583163d8988d3e241d8d03e62c68204ff8ca15706908f49df2a0590cb8e74' '02cfd0491ee143587f56cd8ad1e607dd6270b15a2c829366e5d8bc787f1165b0' 'cd43700e9e5356c6d9b37b2dc5cb41fcccd21c24428ef3a2db6a682210233970')
prepare() {
patch -p1 $pkgname-$pkgver/src/exm-backtrace.c backtrace.patch
patch -p1 $pkgname-$pkgver/src/exm-extension-row.c return-ext.patch
patch -p1 $pkgname-$pkgver/src/exm-installed-page.c return-inst.patch
patch -p1 $pkgname-$pkgver/src/exm-upgrade-assistant.c index.patch
+ patch -p1 $pkgname-$pkgver/src/exm-detail-view.c osc1.patch
+ patch -p1 $pkgname-$pkgver/src/exm-window.c osc2.patch
}
build() {
diff --git a/osc1.patch b/osc1.patch
new file mode 100644
index 000000000000..1adfd2c93901
--- /dev/null
+++ b/osc1.patch
@@ -0,0 +1,15 @@
+diff --git a/src/exm-detail-view.c b/src/exm-detail-view.c
+index f91bb1a..072513e 100644
+--- a/src/exm-detail-view.c
++++ b/src/exm-detail-view.c
+@@ -595,8 +595,8 @@ exm_detail_view_class_init (ExmDetailViewClass *klass)
+ gtk_widget_class_bind_template_callback (widget_class, breakpoint_unapply_cb);
+ gtk_widget_class_bind_template_callback (widget_class, screenshot_view_cb);
+
+- gtk_widget_class_install_action (widget_class, "detail.open-extensions", NULL, open_link);
+- gtk_widget_class_install_action (widget_class, "detail.open-homepage", NULL, open_link);
++ gtk_widget_class_install_action (widget_class, "detail.open-extensions", NULL, (GtkWidgetActionActivateFunc) open_link);
++ gtk_widget_class_install_action (widget_class, "detail.open-homepage", NULL, (GtkWidgetActionActivateFunc) open_link);
+ }
+
+ static void
diff --git a/osc2.patch b/osc2.patch
new file mode 100644
index 000000000000..36ee3c4b442a
--- /dev/null
+++ b/osc2.patch
@@ -0,0 +1,15 @@
+diff --git a/src/exm-window.c b/src/exm-window.c
+index 472c199..ade4ffd 100644
+--- a/src/exm-window.c
++++ b/src/exm-window.c
+@@ -404,7 +404,7 @@ exm_window_init (ExmWindow *self)
+ }
+
+ self->manager = exm_manager_new ();
+- g_signal_connect (self->manager, "error-occurred", on_error, self);
++ g_signal_connect (self->manager, "error-occurred", G_CALLBACK (on_error), self);
+
+ g_object_set (self->installed_page, "manager", self->manager, NULL);
+ g_object_set (self->browse_page, "manager", self->manager, NULL);
+--
+2.45.0