summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-12-10 21:09:10 +0100
committerJoan Bruguera2019-12-10 21:09:10 +0100
commit38304c7294a377e879317104343efd7220e35c2d (patch)
tree512797036a825e624c8d74eacfe7629472c7b308
parent874743c14895df75610dfbd3c8624ab916567161 (diff)
downloadaur-38304c7294a377e879317104343efd7220e35c2d.tar.gz
Upgrade tracking to the latest version. Additionally, change BSC package versioning numbers, in order to include the year in the pkgver. This is to deal with the fact that multiple, different tallbars are routinely released for the same version number. Up until now, this was handled by bumping pkgrel, but this is not the correct way to handle this, since it's not just a rebuild, but just the upstream code changed.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27fd7771349d..32a78008de9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = extrae
pkgdesc = Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).
- pkgver = 3.7.1
- pkgrel = 4
+ pkgver = 3.7.1.20191001
+ pkgrel = 1
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b4cd140bb759..f83004383d57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
-pkgver='3.7.1'
-pkgrel='4'
+pkgver='3.7.1.20191001'
+pkgrel='1'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
depends=(openmpi libunwind papi libxml2 zlib python)
-source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2"
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
extrae-issue-27-fix-pie-address-translation.patch)
sha512sums=(51e8f77082069e2aceaae49d15b9f40cb1f9b66810d334f98f4bb5df5a61b8648b25b0a5adec5ab646d18c45f591fb7762a8a7604a8368ff06938d6e86b12a60
3b0fae157fcc6e85be3a5565c2ea3abe8bf35e130de96435a93ba7b3f4b6c30df8982823d36c494633a2c16671664112558393faeead05226b96aa521bb14fba)
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-${pkgver%.*}"
patch -Np1 -i "$srcdir/extrae-issue-27-fix-pie-address-translation.patch"
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-${pkgver%.*}"
# NOTE: The following optional features are NOT enabled:
# * Automatic instrumentation (with dyninst)
@@ -43,7 +43,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-${pkgver%.*}"
make DESTDIR="$pkgdir/" install
} \ No newline at end of file