summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-14 08:43:44 +0100
committerJoan Bruguera2019-03-14 08:43:44 +0100
commit5186110ebb88ae6aeb358f5b69abbb2e1ba7f652 (patch)
tree12744c0f1307d4c399d83916d2cbef40399fc5f6
parent783c06a2f161c7305074ef295c9e196c5a782fee (diff)
downloadaur-5186110ebb88ae6aeb358f5b69abbb2e1ba7f652.tar.gz
Remove dependence on orphaned dyninst AUR package.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
-rw-r--r--build-fix-dyninst-api.patch15
3 files changed, 6 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0108e717024..983c0d34610e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = extrae
pkgdesc = Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).
pkgver = 3.6.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
@@ -9,13 +9,8 @@ pkgbase = extrae
depends = openmpi
depends = libunwind
depends = papi
- depends = dyninst
- depends = libelf
- depends = libdwarf
source = https://ftp.tools.bsc.es/extrae/extrae-3.6.1-src.tar.bz2
- source = build-fix-dyninst-api.patch
sha512sums = e88435364c31e6de051965a2f23c49be8fdb2afe7542a962c23a35ced3520cfdec308823c4a28f8276ee30eab34708d7e4e7ee8f412740a37e1252d85ea8b356
- sha512sums = 3b4ec3fc71fabb6d1f57a0ccb30cb4ccfa89ec26c062204fbd77fdd0c0f526893938ec37d6e8e6fe86892c2e05dd259f0fb84d45663475fb60084a8237e1b53d
pkgname = extrae
diff --git a/PKGBUILD b/PKGBUILD
index 5cd2aac31ad6..9d21bc2d3efe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,16 @@
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
pkgver='3.6.1'
-pkgrel='1'
+pkgrel='2'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPLv2.1')
-depends=(openmpi libunwind papi dyninst libelf libdwarf)
-source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2"
- build-fix-dyninst-api.patch)
-sha512sums=(e88435364c31e6de051965a2f23c49be8fdb2afe7542a962c23a35ced3520cfdec308823c4a28f8276ee30eab34708d7e4e7ee8f412740a37e1252d85ea8b356
- 3b4ec3fc71fabb6d1f57a0ccb30cb4ccfa89ec26c062204fbd77fdd0c0f526893938ec37d6e8e6fe86892c2e05dd259f0fb84d45663475fb60084a8237e1b53d)
+depends=(openmpi libunwind papi)
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
+sha512sums=(e88435364c31e6de051965a2f23c49be8fdb2afe7542a962c23a35ced3520cfdec308823c4a28f8276ee30eab34708d7e4e7ee8f412740a37e1252d85ea8b356)
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < "$srcdir/build-fix-dyninst-api.patch"
}
build() {
@@ -28,18 +25,10 @@ build() {
--with-unwind=/usr \
--with-unwind-headers=/usr/include \
--with-unwind-libs=/usr/lib \
- --with-dyninst=/usr \
- --with-dyninst-headers=/usr/include \
- --with-dyninst-libs=/usr/lib \
+ --without-dyninst \
--with-papi=/usr \
--with-papi-headers=/usr/include \
--with-papi-libs=/usr/lib \
- --with-dwarf=/usr \
- --with-dwarf-headers=/usr/include \
- --with-dwarf-libs=/usr/lib \
- --with-elf=/usr \
- --with-elf-headers=/usr/include \
- --with-elf-libs=/usr/lib
make
}
diff --git a/build-fix-dyninst-api.patch b/build-fix-dyninst-api.patch
deleted file mode 100644
index 83128557a290..000000000000
--- a/build-fix-dyninst-api.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/src/launcher/dyninst/commonSnippets.C 2019-02-28 23:01:35.667997539 +0100
-+++ b/src/launcher/dyninst/commonSnippets.C 2019-02-28 23:00:25.653420000 +0100
-@@ -482,9 +482,9 @@
- ParseAPI::Block* b = ParseAPI::convert(block);
- void * buf = b->region()->getPtrToInstruction(b->start());
- InstructionAPI::InstructionDecoder dec((unsigned char*)buf,b->size(),b->region()->getArch());
-- InstructionAPI::Instruction::Ptr insn;
-- while((insn = dec.decode())) {
-- res <<loop_name<<"# "<<line++<<": "<< insn->format() << endl;
-+ InstructionAPI::Instruction insn;
-+ while((insn = dec.decode()).isValid()) {
-+ res <<loop_name<<"# "<<line++<<": "<< insn.format() << endl;
- }
- }
- return res.str();