summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera Micó2024-03-10 23:40:50 +0000
committerJoan Bruguera Micó2024-03-10 23:40:50 +0000
commite6e12cf979a7aa0b6ab78edc81a56ef034207518 (patch)
tree1454a517fda1083bad5140d7fb78714d5a6c2696
parentef40b936b12088cf737a43924de067a3c255f165 (diff)
downloadaur-e6e12cf979a7aa0b6ab78edc81a56ef034207518.tar.gz
Fix build with GCC 14
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d3359e4f884..3857ad35f93a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = extrae
pkgdesc = Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).
pkgver = 4.0.6.20230802
- pkgrel = 1
+ pkgrel = 2
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = x86_64
license = LGPL2.1
diff --git a/PKGBUILD b/PKGBUILD
index 13100a524e09..d13b6627c6e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
pkgver='4.0.6.20230802'
-pkgrel='1'
+pkgrel='2'
arch=('x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
@@ -35,6 +35,9 @@ prepare() {
build() {
cd "$srcdir/$pkgname-${pkgver%.*}"
+ # For now, ignore new errors from GCC 14 (see https://gcc.gnu.org/gcc-14/porting_to.html)
+ export CFLAGS="$CFLAGS -Wno-error=incompatible-pointer-types -Wno-error=int-conversion -Wno-error=implicit-function-declaration"
+
# NOTE: The following optional features are NOT enabled:
# * Automatic instrumentation (with dyninst)
# * CUDA support