summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Shark2021-10-24 00:38:11 +0300
committerAndrew Shark2021-10-24 00:38:11 +0300
commitaf4192db71964542055aa9624a13b1b05f8a535d (patch)
tree2e0d644dfd26f8f489be1473deaccb796e31e1dd
downloadaur-af4192db71964542055aa9624a13b1b05f8a535d.tar.gz
release extamaus
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb73e5cb810d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = extramaus
+ pkgdesc = workaround to always show mouse cursor under x11
+ pkgver = 20121220
+ pkgrel = 1
+ url = http://dodger-tools.sourceforge.net/cms/index.php?id=100000201
+ arch = x86_64
+ license = GPLv3 or later
+ makedepends = libx11
+ source = extramaus.c::http://sourceforge.net/projects/dodger-tools/files/vlc/extramaus.c/download
+ sha256sums = 17e0877d51a48f48d22bbafe9746e3d00aea0c0a8085915a8900e8a59911ab55
+
+pkgname = extramaus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d9aea5f923c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Andrew Shark <ashark @ at @ linuxcomp.ru>
+pkgname=extramaus
+pkgver=20121220
+pkgrel=1
+pkgdesc="workaround to always show mouse cursor under x11"
+arch=(x86_64)
+url="http://dodger-tools.sourceforge.net/cms/index.php?id=100000201"
+license=('GPLv3 or later')
+makedepends=(libx11)
+source=(extramaus.c::http://sourceforge.net/projects/dodger-tools/files/vlc/extramaus.c/download)
+sha256sums=(17e0877d51a48f48d22bbafe9746e3d00aea0c0a8085915a8900e8a59911ab55)
+
+build() {
+ gcc extramaus.c -o extramaus -lX11 -lXext -g
+}
+
+package() {
+ install -D extramaus "${pkgdir}/usr/bin/extramaus"
+}