summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2017-10-04 09:38:14 -0400
committerSolomon Choina2017-10-04 09:38:14 -0400
commit8cab2cde9a076452b53983454068752838306858 (patch)
treec713fb7e9ba19d9d1f99b2c922ccb9f2f7fdf283
parent0be553ad23e2c8496c3b17ea935fd020a8cd23fd (diff)
downloadaur-8cab2cde9a076452b53983454068752838306858.tar.gz
update pkgver
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e77d5b1da4c6..3158fbf9d6a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Aug 27 04:16:39 UTC 2017
+# Wed Oct 4 13:38:05 UTC 2017
pkgbase = extraterm
pkgdesc = The swiss army chainsaw of terminal emulators .
- pkgver = 0.27.0
+ pkgver = 0.29.1
pkgrel = 1
url = https://github.com/sedwards2009/extraterm
arch = i686
arch = x86_64
license = MIT
depends = nodejs
- source_i686 = https://github.com/sedwards2009/extraterm/releases/download/v0.27.0/extraterm-0.27.0-linux-ia32.zip
- sha256sums_i686 = 3b71bc410dc1a70e5872d0bb82d4e16264603bb21f3cf9aa7bfa80ec74cc2365
- source_x86_64 = https://github.com/sedwards2009/extraterm/releases/download/v0.27.0/extraterm-0.27.0-linux-x64.zip
- sha256sums_x86_64 = 4154b95b2a8100e4aa4de49ff4abb3d589531a4ed63cf788866f2c900a093e22
+ source_i686 = https://github.com/sedwards2009/extraterm/releases/download/v0.29.1/extraterm-0.29.1-linux-ia32.zip
+ sha256sums_i686 = ec1b81547ed8c0e83409624c88b471819a9fc9c27252dc20d796d3ef55c5162d
+ source_x86_64 = https://github.com/sedwards2009/extraterm/releases/download/v0.29.1/extraterm-0.29.1-linux-x64.zip
+ sha256sums_x86_64 = 0cdce9e4d68a659d4d89f87ff0e46b7204a145148a17cc8e7bebd0ae03afe690
pkgname = extraterm
diff --git a/PKGBUILD b/PKGBUILD
index 4cb38a1a01fc..5d7500a5827a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: mac <poczciwiec at gmail dot com>
pkgname=extraterm
-pkgver=0.27.0
+pkgver=0.29.1
pkgrel=1
pkgdesc="The swiss army chainsaw of terminal emulators . "
arch=("i686" "x86_64")
@@ -11,13 +11,14 @@ license=("MIT")
depends=("nodejs")
source_i686=("$url/releases/download/v$pkgver/extraterm-$pkgver-linux-ia32.zip")
source_x86_64=("$url/releases/download/v$pkgver/extraterm-$pkgver-linux-x64.zip")
-sha256sums_i686=('3b71bc410dc1a70e5872d0bb82d4e16264603bb21f3cf9aa7bfa80ec74cc2365')
-sha256sums_x86_64=('4154b95b2a8100e4aa4de49ff4abb3d589531a4ed63cf788866f2c900a093e22')
+sha256sums_i686=('ec1b81547ed8c0e83409624c88b471819a9fc9c27252dc20d796d3ef55c5162d')
+sha256sums_x86_64=('0cdce9e4d68a659d4d89f87ff0e46b7204a145148a17cc8e7bebd0ae03afe690')
prepare(){
rm -rf "$srcdir/$pkgname-$pkgver"
mv "$srcdir/$pkgname-$pkgver-linux-x64" "$srcdir/$pkgname-$pkgver"
}
+
package() {
cd $srcdir
@@ -28,9 +29,14 @@ package() {
install -d $pkgdir/usr/bin
cp -r "$srcdir/$pkgname-$pkgver"/* "$pkgdir/opt/$pkgname"
- ln -s /opt/extraterm/extraterm $pkgdir/usr/bin/$_pkgname
- # msg2 " -> Installing icons..."
+ install -Dm755 /dev/stdin "$pkgdir"/usr/bin/$_pkgname <<END
+ #!/usr/bin/bash
+ /opt/extraterm/extraterm
+
+END
+
+ msg2 " -> Installing icons..."
local _icon_dir="usr/share/icons/hicolor"
install -Dm644 $pkgdir/opt/$pkgname/resources/app/src/logo/extraterm_small_logo.svg $pkgdir/$_icon_dir/scalable/apps/$pkgname.svg