summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia B2022-10-21 15:09:37 +0200
committerMattia B2022-10-21 15:09:37 +0200
commitc310430a9db8801e243865cd661931dd94fef50f (patch)
tree14a00657c74faed7f4c930ebe75b64db28abb90b
downloadaur-c310430a9db8801e243865cd661931dd94fef50f.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40e1ff19fc3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = eyedropper-git
+ pkgdesc = A simple to use color picker and editor
+ pkgver = 0.4.0.r0.g5272841
+ pkgrel = 1
+ url = https://github.com/FineFindus/eyedropper
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ makedepends = rust
+ depends = gtk4
+ depends = libadwaita
+ provides = eyedropper
+ conflicts = eyedropper
+ source = git+https://github.com/FineFindus/eyedropper.git
+ b2sums = SKIP
+
+pkgname = eyedropper-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5347a583dcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: musiclover <musiclover382@protonmail.com>
+
+pkgname=eyedropper-git
+pkgver=0.4.0.r0.g5272841
+pkgrel=1
+pkgdesc='A simple to use color picker and editor'
+arch=(x86_64)
+url=https://github.com/FineFindus/${pkgname%-git}
+license=(GPL3)
+depends=('gtk4' 'libadwaita')
+makedepends=('git' 'meson' 'rust')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson ${pkgname%-git} build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}