summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2015-06-08 14:57:37 +0200
committerPier Luigi Fiorini2015-06-08 14:57:37 +0200
commit4be911a14bbe1097edf4fb6bfb1ffe34c575dceb (patch)
tree60fcbbc248f21527c8d9e24d604f0da6f8317515
downloadaur-4be911a14bbe1097edf4fb6bfb1ffe34c575dceb.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed32c4d6438e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = eyesight-git
+ pkgdesc = EyeSight: An image viewing program
+ pkgver = 20140929.b2cb444
+ pkgrel = 1
+ url = https://github.com/hawaii-desktop
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ depends = qt5-tools
+ optdepends = qt5-svg: for svg support
+ optdepends = qt5-imageformats: for mng, tga, tiff, bmp image support
+ conflicts = hawaii-eyesight-git
+ replaces = hawaii-eyesight-git
+ options = debug
+ source = eyesight::git://github.com/hawaii-desktop/eyesight.git#branch=master
+ md5sums = SKIP
+
+pkgname = eyesight-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adacc4ebc2b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=eyesight-git
+pkgver=20140929.b2cb444
+pkgrel=1
+pkgdesc="EyeSight: An image viewing program"
+arch=('i686' 'x86_64')
+url="https://github.com/hawaii-desktop"
+license=('GPL2')
+depends=('qt5-base' 'qt5-tools')
+optdepends=('qt5-svg: for svg support'
+ 'qt5-imageformats: for mng, tga, tiff, bmp image support')
+makedepends=('git' 'cmake')
+conflicts=('hawaii-eyesight-git')
+replaces=('hawaii-eyesight-git')
+options=('debug')
+
+_gitroot="git://github.com/hawaii-desktop/eyesight.git"
+_gitbranch=master
+_gitname=eyesight
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${_gitname}
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake ../${_gitname} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}