summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Etherington2022-03-24 01:43:10 +0200
committerConnor Etherington2022-03-24 01:43:10 +0200
commit6f6a20407c04dd1743c1ef9c09dee8e866d33db9 (patch)
treeba4db4067290888e48333de48285d064e46914df
parent8aa7caf51374712a9e969c600654203df9618819 (diff)
downloadaur-6f6a20407c04dd1743c1ef9c09dee8e866d33db9.tar.gz
Update.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 19 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9fd08fa3cf7..1d857968cf8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,11 +2,16 @@ pkgbase = ez
pkgdesc = Task simplificaltion aimed at increasing the speed and efficiency of common tasks
pkgver = 1.0.r1
pkgrel = 1
- url = https://gitlab.com/qYp/ez
+ url = https://gitlab.com/qYp/EZ
arch = x86_64
license = MIT
- makedepends = git
+ optdepends = npn: To download npm packages with ezdl
+ optdepends = snapd: To install snap packages with ezdl
+ optdepends = pip: To install python packages with ezdl
+ optdepends = git: To use ezgc for git cloning
+ optdepends = lf: To use eztsts lf file-management functionality
+ optdepends = paru: To use ezdl for downloading packages from the AUR
source = https://gitlab.com/qYp/concise/-/raw/master/x86_64/ez-1.0.r1-1-x86_64.pkg.tar.zst
- sha256sums = 00910f76353d6a68510c4feb20a4583e630459e9ae4d94676a9749e75fff73f9
+ sha256sums = 661be8bd668269367de818ba01efc6fc8baa4c202a329925aa409f5082ed3b9f
pkgname = ez
diff --git a/PKGBUILD b/PKGBUILD
index c1053f475068..59a15a4e4dde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,24 @@
# Maintainer: Connor Etherington <connor@concise.cc>
# ---
+_pkgname=EZ
pkgname=ez
pkgver=1.0.r1
pkgrel=1
pkgdesc='Task simplificaltion aimed at increasing the speed and efficiency of common tasks'
arch=(x86_64)
-url="https://gitlab.com/qYp/${pkgname}"
+url="https://gitlab.com/qYp/${_pkgname}"
license=('MIT')
depends=()
-makedepends=(git)
+optdepends=(
+ 'npn: To download npm packages with 'ezdl''
+ 'snapd: To install snap packages with 'ezdl''
+ 'pip: To install python packages with 'ezdl''
+ 'git: To use 'ezgc' for git cloning'
+ 'lf: To use 'eztst's lf file-management functionality'
+ 'paru: To use 'ezdl' for downloading packages from the AUR'
+ )
source=("https://gitlab.com/qYp/concise/-/raw/master/x86_64/${pkgname}-${pkgver}-${pkgrel}-$arch.pkg.tar.zst")
-sha256sums=('00910f76353d6a68510c4feb20a4583e630459e9ae4d94676a9749e75fff73f9')
+sha256sums=('661be8bd668269367de818ba01efc6fc8baa4c202a329925aa409f5082ed3b9f')
package() {
install -Dm775 usr/bin/* -g wheel -o ${USER} -t "${pkgdir}/usr/bin/"