summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2020-07-06 12:27:51 -0400
committerbrent s2020-07-06 12:27:51 -0400
commit2770f5d4df6af471e1732affd0d0c1f86e55da68 (patch)
treefd562cd05267d30370af70c8580cb64e4a5a73f6
parent08bc0835085e4a294bd5a1dcd6b490dfed8245a1 (diff)
downloadaur-2770f5d4df6af471e1732affd0d0c1f86e55da68.tar.gz
fixing for GCC update
confirmed working. GCC9 is currently in [community-testing].
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a9c76b97e63..83ff8065e5a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = ezquake
pkgdesc = One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play.
pkgver = 3.2
- pkgrel = 1
+ pkgrel = 2
url = http://ezquake.sourceforge.net/
install = ezquake.install
arch = x86_64
license = GPL
makedepends = unzip
makedepends = vim
+ makedepends = gcc9
depends = curl
depends = expat
depends = jansson
diff --git a/PKGBUILD b/PKGBUILD
index 51eb48ebcd33..cf67613e4411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=ezquake
pkgver=3.2
-pkgrel=1
+pkgrel=2
pkgdesc="One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play."
url="http://ezquake.sourceforge.net/"
license=('GPL')
depends=('curl' 'expat' 'jansson' 'libjpeg-turbo' 'libpng' 'openssl' 'sdl2' 'speex')
-makedepends=('unzip' 'vim')
+makedepends=('unzip' 'vim' 'gcc9')
conflicts=('ezquake-git' 'fuhquake')
provides=('quake' 'fuhquake')
arch=('x86_64')
@@ -26,7 +26,7 @@ build() {
cd "${srcdir}/ezquake-source-${pkgver}/"
# Compile ezquake
- make
+ make CC="gcc-9"
}
package() {