summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2016-06-18 15:01:44 -0400
committerSlashbunny2016-06-18 15:01:44 -0400
commitc0f14d514ee379b7cafd49061722a123b201ae95 (patch)
tree6c9ceb452d7fc538a95a3de3d6d1aed22a63dfee
parent569432ffd125aec53b1337e9fc5c5ad36188694d (diff)
downloadaur-c0f14d514ee379b7cafd49061722a123b201ae95.tar.gz
Update to ezquake3.0, compile binary from source
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD49
-rw-r--r--ezquake.launcher2
4 files changed, 44 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cf178b38a2d..80b8e29df1e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,33 @@
+# Generated by mksrcinfo v8
+# Sat Jun 18 19:01:27 UTC 2016
pkgbase = ezquake
pkgdesc = One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play.
- pkgver = 2.2
+ pkgver = 3.0
pkgrel = 1
url = http://ezquake.sourceforge.net/
install = ezquake.install
- arch = i686
arch = x86_64
license = GPL
makedepends = unzip
- depends = libgl
- depends = libxxf86dga
+ depends = curl
+ depends = expat
+ depends = jansson
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = openssl
+ depends = sdl2
provides = quake
provides = fuhquake
conflicts = fuhquake
- noextract = ezquake_linux64_2.2.tar.gz
- noextract = ezquake_linux64_2.1.tar.gz
- source = http://downloads.sourceforge.net/sourceforge/ezquake/ezquake_linux64_2.2.tar.gz
- source = http://downloads.sourceforge.net/sourceforge/ezquake/ezquake_linux64_2.1.tar.gz
+ noextract = ezquake_linux64_3.0-full.tar.gz
+ source = https://github.com/ezQuake/ezquake-source/archive/v3.0.tar.gz
+ source = https://github.com/ezQuake/ezquake-source/releases/download/v3.0/ezquake_linux64_3.0-full.tar.gz
source = ezquake.launcher
source = ezquake.desktop
source = ezquake.ico
- sha256sums = b7735c680403678955f7d04a51265d216fb787fbdb343628b69418bfdb5c7203
- sha256sums = b3f2de84bd71904895910be9be621cd5462cf689007e9a5e8a6ed3acdfa8b981
- sha256sums = b5099392cc02ac0b4a7f073542b7e240b78842c36ac8d0921bbb85a1221e5d45
+ sha256sums = 825ffbdb5a2aaea321350a500af488ca9d842423e6798b252966b89b83ad59f2
+ sha256sums = 5ac53c8317eb878dbb3ac33da8fa6572f02aee3302ac0fab03e7f1cdf3d4575f
+ sha256sums = bc512722c0143139a8dad77beac3ef260f00bc20e7f36e083cdd5870e71a90b6
sha256sums = e92b9cdeac5eadced50a6167eb53b1343b0772d3bf8afa310eb281b88bf7e677
sha256sums = 2a6a5484ddb4cfaf8518b51df39ffd1fa8ce768402eab6401415bececb8e8ab2
diff --git a/.gitignore b/.gitignore
index e4f398dc5b3a..c1a2d5a7d161 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,5 @@ pkg/
*.pkg.tar.xz
*.pkg.tar
*.src.tar.gz
+ezquake_linux64_3.0-full.tar.gz
+v3.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index e7f0d2a432c4..2ed4eb72a435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,33 @@
# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
pkgname=ezquake
-pkgver=2.2
+pkgver=3.0
pkgrel=1
pkgdesc="One of the most Popular QuakeWorld clients for Linux/BSD/OSX/Win32. You need the retail pak files to play."
url="http://ezquake.sourceforge.net/"
license=('GPL')
-depends=('libgl' 'libxxf86dga')
+depends=('curl' 'expat' 'jansson' 'libjpeg-turbo' 'libpng' 'openssl' 'sdl2')
makedepends=('unzip')
conflicts=('fuhquake')
provides=('quake' 'fuhquake')
-arch=('i686' 'x86_64')
+arch=('x86_64')
install=ezquake.install
-source=("http://downloads.sourceforge.net/sourceforge/ezquake/ezquake_linux64_${pkgver}.tar.gz"
-'http://downloads.sourceforge.net/sourceforge/ezquake/ezquake_linux64_2.1.tar.gz'
+source=("https://github.com/ezQuake/ezquake-source/archive/v${pkgver}.tar.gz"
+"https://github.com/ezQuake/ezquake-source/releases/download/v3.0/ezquake_linux64_${pkgver}-full.tar.gz"
'ezquake.launcher' 'ezquake.desktop' 'ezquake.ico')
-noextract=("ezquake_linux64_${pkgver}.tar.gz" 'ezquake_linux64_2.1.tar.gz')
-sha256sums=('b7735c680403678955f7d04a51265d216fb787fbdb343628b69418bfdb5c7203'
- 'b3f2de84bd71904895910be9be621cd5462cf689007e9a5e8a6ed3acdfa8b981'
- 'b5099392cc02ac0b4a7f073542b7e240b78842c36ac8d0921bbb85a1221e5d45'
+noextract=("ezquake_linux64_${pkgver}-full.tar.gz")
+sha256sums=('825ffbdb5a2aaea321350a500af488ca9d842423e6798b252966b89b83ad59f2'
+ '5ac53c8317eb878dbb3ac33da8fa6572f02aee3302ac0fab03e7f1cdf3d4575f'
+ 'bc512722c0143139a8dad77beac3ef260f00bc20e7f36e083cdd5870e71a90b6'
'e92b9cdeac5eadced50a6167eb53b1343b0772d3bf8afa310eb281b88bf7e677'
'2a6a5484ddb4cfaf8518b51df39ffd1fa8ce768402eab6401415bececb8e8ab2')
-if [ $CARCH = 'i686' ]; then
- source[0]="http://downloads.sourceforge.net/sourceforge/ezquake/ezquake_linux32_${pkgver}.tar.gz"
- source[1]='http://downloads.sourceforge.net/sourceforge/ezquake/ezquake_linux32_2.1.tar.gz'
- md5sums[0]='655e8ec60c619ab5d1435882436296b88fc279c2963f01dd277f34939336c067'
- md5sums[1]='bf322d27ae182258ca2d9083ccaa26eda12efe52b075583d327353b87e702310'
- noextract=("ezquake_linux32_${pkgver}.tar.gz" 'ezquake_linux32_2.1.tar.gz')
-fi
+build() {
+ cd "${srcdir}/ezquake-source-${pkgver}"
+
+ # Compile ezquake
+ make
+}
package() {
cd "${srcdir}"
@@ -36,14 +35,16 @@ package() {
# Create Destination Directories
install -d "${pkgdir}/opt/quake"
- # Unpack ezQuake
- if [ $CARCH = 'x86_64' ]; then
- bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake_linux64_2.1.tar.gz"
- bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake_linux64_${pkgver}.tar.gz"
- else
- bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake_linux32_2.1.tar.gz"
- bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake_linux32_${pkgver}.tar.gz"
- fi
+ # Unpack ezQuake assets package
+ bsdtar -x -o -C "${pkgdir}/opt/quake" -f "${srcdir}/ezquake_linux64_${pkgver}-full.tar.gz"
+
+ # Clean up permissions in assets package
+ find "${pkgdir}/opt/quake" -type d -exec chmod 0755 "{}" \;
+ find "${pkgdir}/opt/quake" -type f -exec chmod 0644 "{}" \;
+
+ # Overwrite packaged binary with compiled one
+ mv -v "${srcdir}/ezquake-source-${pkgver}/ezquake-linux-x86_64" \
+ "${pkgdir}/opt/quake/"
# Make id1 Directory for pak0.pak and pak1.pak files
install -d "${pkgdir}/opt/quake/id1/"
diff --git a/ezquake.launcher b/ezquake.launcher
index a6adfb38d294..bc4e5355308e 100644
--- a/ezquake.launcher
+++ b/ezquake.launcher
@@ -1,5 +1,5 @@
#!/bin/bash
cd "/opt/quake"
-./ezquake-gl.glx +cfg_use_home 1 "$@"
+./ezquake-linux-x86_64 +cfg_use_home 1 "$@"
exit $?