summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-28 01:04:20 +0300
committerCaleb Maclennan2020-02-28 01:04:20 +0300
commit02285d2a1e991f818fddb52365241378404858a9 (patch)
tree2472b337cb9fcbc17da98a52128e46c4e628ec60
parent909620802f7a52a1c36c42961f4177eb0ebe4cdf (diff)
downloadaur-02285d2a1e991f818fddb52365241378404858a9.tar.gz
Use more upstream rebuild stuff, however dirty electron is
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afee317e0c34..400ac42c23bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,14 +5,15 @@ pkgbase = ezra-project
url = https://github.com/tobias-klein/ezra-project
arch = x86_64
license = GPL3
+ makedepends = cmake
makedepends = npm
makedepends = sword
- makedepends = cmake
+ depends = biblesync
+ depends = curl
depends = electron
+ depends = icu
depends = nodejs
depends = sqlite
- depends = curl
- depends = icu
conflicts = ezra-project-git
source = https://github.com/tobias-klein/ezra-project/archive/0.11.1.tar.gz
source = ezra-project.sh
diff --git a/PKGBUILD b/PKGBUILD
index 1c3511dd82ec..75974eb1e5e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,13 @@ pkgdesc="a bible study software focussing on topical study based on keywords/tag
arch=('x86_64')
url="https://github.com/tobias-klein/ezra-project"
license=('GPL3')
-depends=('electron' 'nodejs' 'sqlite' 'curl' 'icu')
-makedepends=('npm' 'sword' 'cmake')
+depends=('biblesync'
+ 'curl'
+ 'electron'
+ 'icu'
+ 'nodejs'
+ 'sqlite')
+makedepends=('cmake' 'npm' 'sword')
conflicts=("$pkgname-git")
source=("https://github.com/tobias-klein/$pkgname/archive/$pkgver.tar.gz"
'ezra-project.sh'
@@ -26,8 +31,12 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- # npm run rebuild-linux
+ npm run compile-pug
+ npm run install-node-prune
"$(npm bin)"/electron-rebuild -f -w node-sword-interface -v "$_electron"
+ npm run prune-node-modules
+ npm run purge-build-artifacts
+ npm run cleanup-gyp-shebang
}
package() {