summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-04-01 17:57:16 +0300
committerCaleb Maclennan2020-04-01 17:57:33 +0300
commit2998d3214a5e1a933b40b2ed2c57045251be0f15 (patch)
treea85f9e8f34a06180764501c832e4ec5cbd825408
parentff7b8125968a3d8112fdbb6b22f8f5a356c7d0b7 (diff)
downloadaur-2998d3214a5e1a933b40b2ed2c57045251be0f15.tar.gz
Make build() work offline, install licence to correct place
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f0ca5448282..667699ade0df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ezra-project
pkgdesc = Bible study software focussing on topical study based on keywords/tags
pkgver = 0.12.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/tobias-klein/ezra-project
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 60dc4d9c180a..98a27671357a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ezra-project
pkgver=0.12.0
-pkgrel=2
+pkgrel=3
pkgdesc='Bible study software focussing on topical study based on keywords/tags'
arch=('x86_64')
url="https://github.com/tobias-klein/$pkgname"
@@ -22,19 +22,18 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
'ezra-project.sh')
sha256sums=('43a51c7ffb6a5f36b3b692a645169a77523ec305c630d84fada542745fce37ad'
'0a36167bce248b6082045163cf60b143d02ca1e447a791cf0c88e960a7fdc618')
-_electron="$(electron --version | sed 's/^v//')"
prepare() {
cd "$pkgname-$pkgver"
jq 'del(.dependencies["node-addon-api", "node-sword-interface"], .devDependencies["electron", "electron-osx-sign", "node-abi", "node-gyp", "pug-cli", "sequelize-cli"])' package.json |
sponge package.json
+ npm install --cache "$srcdir/npm-cache" --no-audit --no-fund
}
build() {
cd "$pkgname-$pkgver"
rm -f node_modules/{node-addon-api,node-sword-interface}
local _electron="$(electron --version | sed 's/^v//')"
- npm install --cache "$srcdir/npm-cache" --no-audit --no-fund
npx electron-rebuild --version="$_electron"
node-prune node_modules
npx electron-packager ./ "$pkgname" --electron-version="$_electron"
@@ -53,6 +52,6 @@ package() {
install -Dm755 "../$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
install -Dm644 -t "$pkgdir/usr/share/applications/" "$pkgname.desktop"
install -Dm644 -t "$pkgdir/usr/lib/$pkgname/resources/" "$pkgname-linux-x64/resources/app.asar"
- install -Dm644 -t "$pkgdir/usr/share/licences/$pkgname/" LICENSE
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" {CHANGELOG,README,TECH,LOC_METRICS}.md
}