summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-28 12:36:55 +0300
committerCaleb Maclennan2020-03-03 17:09:25 +0300
commitb19913f06dfdc35425d629b6d668bd8cbaac09bc (patch)
tree733ad7f78974f5d88f427aa248e2aac3141293e9
parentfc9fa90a95a99d419f7b1a40fec820e2b240844c (diff)
downloadaur-b19913f06dfdc35425d629b6d668bd8cbaac09bc.tar.gz
Use gendesk so desktop file stays in step
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--ezra-project.desktop7
3 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29469545b27a..59498235d68b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = ezra-project
- pkgdesc = a bible study software focussing on topical study based on keywords/tags
+ pkgdesc = Bible study software focussing on topical study based on keywords/tags
pkgver = 0.11.1
pkgrel = 3
url = https://github.com/tobias-klein/ezra-project
arch = x86_64
license = GPL3
makedepends = cmake
+ makedepends = gendesk
makedepends = npm
makedepends = sword
depends = curl
@@ -16,10 +17,8 @@ pkgbase = ezra-project
conflicts = ezra-project-git
source = https://github.com/tobias-klein/ezra-project/archive/0.11.1.tar.gz
source = ezra-project.sh
- source = ezra-project.desktop
sha256sums = cf662fc55d658d5e03ed95025428b81b1d12cb6d3f0aed9b6e41278f80b65ecd
sha256sums = 0a36167bce248b6082045163cf60b143d02ca1e447a791cf0c88e960a7fdc618
- sha256sums = f89adcdecca5b0684679a4c4060a7e0398b5d332b2377e0fb0e115969d94e116
pkgname = ezra-project
diff --git a/PKGBUILD b/PKGBUILD
index f7e59dc35e0b..0506e009c740 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ezra-project
pkgver=0.11.1
pkgrel=3
-pkgdesc="a bible study software focussing on topical study based on keywords/tags"
+pkgdesc="Bible study software focussing on topical study based on keywords/tags"
arch=('x86_64')
url="https://github.com/tobias-klein/ezra-project"
license=('GPL3')
@@ -12,20 +12,19 @@ depends=('curl'
'icu'
'nodejs'
'sqlite')
-makedepends=('cmake' 'npm' 'sword')
+makedepends=('cmake' 'gendesk' 'npm' 'sword')
conflicts=("$pkgname-git")
source=("https://github.com/tobias-klein/$pkgname/archive/$pkgver.tar.gz"
- 'ezra-project.sh'
- 'ezra-project.desktop')
+ 'ezra-project.sh')
sha256sums=('cf662fc55d658d5e03ed95025428b81b1d12cb6d3f0aed9b6e41278f80b65ecd'
- '0a36167bce248b6082045163cf60b143d02ca1e447a791cf0c88e960a7fdc618'
- 'f89adcdecca5b0684679a4c4060a7e0398b5d332b2377e0fb0e115969d94e116')
+ '0a36167bce248b6082045163cf60b143d02ca1e447a791cf0c88e960a7fdc618')
_electron="$(electron --version | sed 's/^v//')"
prepare() {
cd "$pkgname-$pkgver"
npm uninstall --no-audit -D electron
npm install --no-audit electron@"$_electron"
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name "Ezra Project"
}
build() {
@@ -39,7 +38,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
- install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 -t "$pkgdir/usr/share/applications/" "$pkgname.desktop"
install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
"$(npm bin)"/electron-packager . "$pkgname" --overwrite --asar --platform=linux --arch=x64 --prune=true --out=release --electron-version="$_electron"
rm release/ezra-project-linux-x64/"$pkgname"
diff --git a/ezra-project.desktop b/ezra-project.desktop
deleted file mode 100644
index 1cc8b52d3ad6..000000000000
--- a/ezra-project.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=Ezra Project
-Comment=Bible study software focussing on topical study based on keywords
-Exec=ezra-project
-Terminal=false
-Type=Application
-Icon=ezra-project