summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-07 14:12:00 +0300
committerCaleb Maclennan2020-03-07 14:23:26 +0300
commit82a7fc284b4f5b6af1794565e3bec43e13548c73 (patch)
treeb1a0b5f4f1ef78e7099494c65e0d317744e785f6
parent174296c5b28ebd8bc56bab0b3bfacb379f83d611 (diff)
downloadaur-82a7fc284b4f5b6af1794565e3bec43e13548c73.tar.gz
Update desktop launcher with better details
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5658e91f825d..18661d70ef57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ezra-project-git
- pkgdesc = Bible study software focussing on topical study based on keywords/tags
+ pkgdesc = Bible study tool focussing on topical study based on keywords/tags
pkgver = 0.11.1.r93.g93f5777
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/tobias-klein/ezra-project
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index b21e85f5559a..6842924bfd7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=ezra-project-git
pkgver=0.11.1.r93.g93f5777
-pkgrel=4
-pkgdesc='Bible study software focussing on topical study based on keywords/tags'
+pkgrel=5
+pkgdesc='Bible study tool focussing on topical study based on keywords/tags'
arch=('x86_64')
url="https://github.com/tobias-klein/${pkgname%-git}"
license=('GPL3')
@@ -33,10 +33,15 @@ pkgver() {
}
prepare() {
+ # TODO: use of gendesk will probably be obsolete in the next release, see:
+ # https://github.com/tobias-klein/ezra-project/pull/25
+ gendesk -f -n \
+ --name "Ezra Project" \
+ --categories="Education;Spirituality;DataVisualization;Literature" \
+ --genericname="Bible Study Tool"
cd "${pkgname%-git}"
jq 'del(.dependencies["node-addon-api", "node-sword-interface"], .devDependencies["electron", "electron-osx-sign", "node-abi", "node-gyp", "pug-cli", "sequelize-cli"])' package.json |
sponge package.json
- gendesk -f -n --pkgname "${pkgname%-git}" --pkgdesc "${pkgname%-git}" --name "Ezra Project"
}
build() {
@@ -58,7 +63,7 @@ build() {
package() {
cd "${pkgname%-git}"
install -Dm755 "../${pkgname%-git}.sh" "$pkgdir/usr/bin/${pkgname%-git}"
- install -Dm644 -t "$pkgdir/usr/share/applications/" "${pkgname%-git}.desktop"
+ install -Dm644 -t "$pkgdir/usr/share/applications/" "$srcdir/${pkgname%-git}.desktop"
install -Dm644 -t "$pkgdir/usr/lib/${pkgname%-git}/resources/" "${pkgname%-git}-linux-x64/resources/app.asar"
install -Dm644 -t "$pkgdir/usr/share/licences/${pkgname%-git}/" LICENSE
}