summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-18 09:10:26 +0800
committerzxp198210052024-01-18 09:10:26 +0800
commitd4407852b187ad1a117db410f58355fb321a6e3d (patch)
tree6e5eb6d2dda0f9e140d01dcb08352772403e7d62
parent8bc7314b4f3c23406e002de9e473a2f0324d32b0 (diff)
downloadaur-d4407852b187ad1a117db410f58355fb321a6e3d.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--ezytdl.sh13
3 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 141171918e36..d7642aa11643 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = ezytdl-bin
pkgdesc = An application that leverages yt-dlp and FFmpeg to provide a simple, easy-to-use interface for downloading videos from YouTube, Twitch, SoundCloud, and various other sites.
pkgver = 2.4.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/sylviiu/ezytdl
arch = x86_64
license = GPL3
- makedepends = asar
+ makedepends = squashfuse
depends = electron25
depends = ffmpeg
depends = libdbusmenu-glib
depends = libxext
depends = gdk-pixbuf2
+ depends = libnotify
provides = ezytdl=2.4.2
conflicts = ezytdl
source = ezytdl-2.4.2.AppImage::https://github.com/sylviiu/ezytdl/releases/download/2.4.2/ezytdl-linux.AppImage
source = ezytdl.sh
sha256sums = 1b26c8c467aa8f3025b69aecab6739be495244b9551fd59ad99007a613a13efe
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = ezytdl-bin
diff --git a/PKGBUILD b/PKGBUILD
index 58d8ad8dbf7a..0b6ab191c05c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ezytdl-bin
pkgver=2.4.2
_electronversion=25
-pkgrel=2
+pkgrel=3
pkgdesc="An application that leverages yt-dlp and FFmpeg to provide a simple, easy-to-use interface for downloading videos from YouTube, Twitch, SoundCloud, and various other sites. "
arch=('x86_64')
url="https://github.com/sylviiu/ezytdl"
@@ -15,16 +15,17 @@ depends=(
'libdbusmenu-glib'
'libxext'
'gdk-pixbuf2'
+ 'libnotify'
)
makedepends=(
- 'asar'
+ 'squashfuse'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/${pkgver}/${pkgname%-bin}-linux.AppImage"
"${pkgname%-bin}.sh"
)
sha256sums=('1b26c8c467aa8f3025b69aecab6739be495244b9551fd59ad99007a613a13efe'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -33,12 +34,12 @@ build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
asar e "${srcdir}/squashfs-root/resources/app.asar" "${srcdir}/app"
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
- cp -r "${srcdir}/app" "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/ezytdl.sh b/ezytdl.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/ezytdl.sh
+++ b/ezytdl.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file