summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-09-15 14:20:47 +0100
committerGrey Christoforo2015-09-15 14:20:47 +0100
commit2b59c9c6163b8353a5f7dcba6904616b5d6ea0ca (patch)
tree74b4b16e403a3c3afebba8e943d52bc8780f8028
downloadaur-2b59c9c6163b8353a5f7dcba6904616b5d6ea0ca.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
-rw-r--r--arch.patch20
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..442737e9ce4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = f-engrave
+ pkgver = 1.51
+ pkgrel = 1
+ url = https://github.com/Ultimaker/libArcus
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = python
+ depends = ttf2cxf
+ source = http://www.scorchworks.com/Fengrave/F-Engrave-1.51_src.zip
+ source = arch.patch
+ md5sums = e17d5345f703b05618b9c1eae6b81ce2
+ md5sums = caaaccdcf81467703183aba4b2b176cb
+
+pkgname = f-engrave
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..63929b1b0556
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+pkg
+src
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..525ef1b3fca5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=f-engrave
+pkgver=1.51
+pkgrel=1
+pkgdesc=""
+url="https://github.com/Ultimaker/libArcus"
+arch=('i686' 'x86_64')
+license=('unknown')
+depends=('python' 'ttf2cxf')
+source=(http://www.scorchworks.com/Fengrave/F-Engrave-${pkgver}_src.zip arch.patch)
+md5sums=('e17d5345f703b05618b9c1eae6b81ce2'
+ 'd0f798648d842560300f8350e8da3f26')
+
+prepare() {
+ cd F-Engrave-${pkgver}_src
+ patch < ../arch.patch
+}
+
+package() {
+ cd F-Engrave-${pkgver}_src
+ install -Dm755 f-engrave-151.py "$pkgdir/usr/bin/f-engrave"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/arch.patch b/arch.patch
new file mode 100644
index 000000000000..7b9a343e9126
--- /dev/null
+++ b/arch.patch
@@ -0,0 +1,20 @@
+--- f-engrave-151.py 2015-09-07 23:11:36.000000000 +0100
++++ f-engrave-151.py.new 2015-09-15 14:18:05.078678057 +0100
+@@ -1617,7 +1617,7 @@
+ stdout, stderr = p.communicate()
+ if VERSION == 3:
+ stdout = bytes.decode(stdout)
+- if str.find(stdout.upper(),'TTF2CXF') != -1:
++ if str.find(stdout.upper(),'TTF FILE') != -1:
+ self.TTF_AVAIL = TRUE
+ else:
+ self.TTF_AVAIL = FALSE
+@@ -1801,7 +1801,7 @@
+ self.H_CALC.set("max_use")
+ self.plotbox.set("no_box")
+ self.boxgap.set("0.25")
+- self.fontdir.set("fonts")
++ self.fontdir.set("/usr/share/fonts/TTF")
+ self.cut_type.set("engrave") # Options are "engrave" and "v-carve"
+ self.input_type.set("text") # Options are "text" and "image"
+