summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-08 10:54:01 +0000
committerGrey Christoforo2019-02-08 10:54:01 +0000
commit75788a3dc75e1867a9e4f821a56fcb20e5f31b92 (patch)
tree89d29c0509d950a78b0c07027027c1d4a3686552
parent9eaa1553a6f02b44f0fc07af8acfa43b3d764cd1 (diff)
downloadaur-75788a3dc75e1867a9e4f821a56fcb20e5f31b92.tar.gz
fix stuff that broke
-rw-r--r--PKGBUILD9
-rw-r--r--arch.patch4
2 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50c08f96db05..021fae750b0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=f-engrave
pkgver=1.66
-pkgrel=1
+pkgrel=2
pkgdesc="Supports Engraving and V-Carving"
url="http://www.scorchworks.com/Fengrave/fengrave.html"
arch=('x86_64')
@@ -11,12 +11,13 @@ makedepends=('dos2unix')
depends=('python')
source=(http://www.scorchworks.com/Fengrave/F-Engrave-${pkgver}_src.zip arch.patch)
md5sums=('63dbde2b6472d66a847438481208457e'
- 'f1844c9323b52b92f8e12f922ff50965')
+ '0024e18a0fd00d5fd455b783264e6923')
prepare() {
cd F-Engrave-${pkgver}_src
+ #sed -i "s,159,${pkgver//./},g" -i ../arch.patch
patch < ../arch.patch
- dos2unix ${pkgname}-${pkgver/./}.py
+ dos2unix ${pkgname}.py
}
build() {
@@ -26,7 +27,7 @@ build() {
package() {
cd F-Engrave-${pkgver}_src
- install -Dm755 ${pkgname}-${pkgver/./}.py "$pkgdir/usr/bin/${pkgname}"
+ install -Dm755 ${pkgname}.py "$pkgdir/usr/bin/${pkgname}"
cd TTF2CXF_STREAM
install -Dm755 ttf2cxf_stream "$pkgdir/usr/bin/ttf2cxf_stream"
}
diff --git a/arch.patch b/arch.patch
index 21c185f63373..a288c088135a 100644
--- a/arch.patch
+++ b/arch.patch
@@ -1,5 +1,5 @@
---- f-engrave-159.py 2015-09-07 23:11:36.000000000 +0100
-+++ f-engrave-159.py.new 2015-09-15 14:18:05.078678057 +0100
+--- f-engrave.py 2015-09-07 23:11:36.000000000 +0100
++++ f-engrave.py.new 2015-09-15 14:18:05.078678057 +0100
@@ -1801,7 +1801,7 @@
self.H_CALC.set("max_use")
self.plotbox.set("no_box")