summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiretza2017-04-17 23:34:49 +0200
committerxiretza2017-04-17 23:34:49 +0200
commit69db9f772ce196357f3828f1e782f402a0fd6f50 (patch)
tree73f56275f2c782b135438ea534f960c24d1b5014
parentd2e574669e5515d115ece38121036d42ddd86a1e (diff)
downloadaur-69db9f772ce196357f3828f1e782f402a0fd6f50.tar.gz
fix makedeps, update source, package COPYRIGHT
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02802d9fdfcf..2e2b1ec15858 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = f2c
pkgdesc = Fortran to C code translator
pkgver = 1.0
- pkgrel = 8
+ pkgrel = 9
url = http://www.netlib.org/f2c/index.html
arch = x86_64
arch = i686
license = custom
- source = git://github.com/juanjosegarciaripoll/f2c.git#commit=90cda47429
+ makedepends = git
+ source = git://github.com/juanjosegarciaripoll/f2c.git#commit=d01fe07
md5sums = SKIP
pkgname = f2c
diff --git a/PKGBUILD b/PKGBUILD
index 80f0b0a27ed1..1e4400d2098b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
-# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Maintainer: xiretza <xiretza+aur@gmail.com>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Jesin <jesin00@gmail.com>
# Contributor: Gabriele Lanaro <gabriele.lanaro@gmail.com>
pkgname=f2c
pkgver=1.0
-pkgrel=8
+pkgrel=9
pkgdesc='Fortran to C code translator'
url='http://www.netlib.org/f2c/index.html'
license=('custom')
+makedepends=('git')
arch=('x86_64' 'i686')
-source=("git://github.com/juanjosegarciaripoll/f2c.git#commit=90cda47429")
+source=("git://github.com/juanjosegarciaripoll/f2c.git#commit=d01fe07")
md5sums=('SKIP')
prepare() {
@@ -25,6 +27,7 @@ build() {
package() {
make -C "$pkgname" DESTDIR="$pkgdir" install
+ install -Dm644 "${pkgname}/COPYRIGHT" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}
# vim:set ts=2 sw=2 et: