summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2021-12-30 01:39:03 +0100
committerAntoine Viallon2021-12-30 01:39:03 +0100
commit686685b265d3c60f496533fffec792e1254f6b93 (patch)
tree3dd9dc7f0622c26c8a30b16b378cc0cdc84f7509
parent2ce12d4b488a579ce95b0aa192b7b11eb5062ae2 (diff)
downloadaur-686685b265d3c60f496533fffec792e1254f6b93.tar.gz
Fix pkgver
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e15c27b7d6fe..90a829c61072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = f2fs-tools-progress-patch-git
pkgdesc = Tools for Flash-Friendly File System (F2FS) with progress feedback
- pkgver = 794.git.27bf6c7
+ pkgver = 1.13.0.r142.g27bf6c7
pkgrel = 1
url = https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/about/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 010cc77fe1c0..0b12cc87acec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: vinibali <vinibali1 at gmail.com>
pkgname=f2fs-tools-progress-patch-git
-pkgver=794.git.27bf6c7
+pkgver=1.13.0.r142.g27bf6c7
pkgrel=1
pkgdesc='Tools for Flash-Friendly File System (F2FS) with progress feedback'
arch=('x86_64')
@@ -21,10 +21,8 @@ source=("$pkgname::git+https://gitlab.lesviallon.fr/aviallon/f2fs-tools.git")
sha256sums=('SKIP')
pkgver() {
- cd $srcdir/$pkgname
- no=$(git rev-list --count HEAD)
- hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
- printf "${no}.git.${hash}"
+ cd "$pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {