summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-25 12:28:47 +1300
committercaltlgin2020-11-25 12:28:47 +1300
commit8c5510b2d23507da9a07d6142ecf35cb1e65e01b (patch)
tree4493f9d17ed614c697f17f6c7b6fd354dd19d2ab
parent40372814f70170e0f5dc1c09bafe4f3de4144dd0 (diff)
downloadaur-8c5510b2d23507da9a07d6142ecf35cb1e65e01b.tar.gz
Update to v8.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
3 files changed, 24 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 719155e58775..f1180a8e6ffa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,13 @@
pkgbase = f3
- pkgdesc = Utilities to detect and repair counterfeit flash storage, i.e. thumb drives and memory cards with less flash than advertised
- pkgver = 7.2
+ pkgdesc = Simple tool that tests flash cards capacity and performance to see if they live up to claimed specifications
+ pkgver = 8.0
pkgrel = 1
- url = http://oss.digirati.com.br/f3/
- arch = armv7h
- arch = aarch64
- arch = i686
+ url = https://github.com/AltraMayor/f3
arch = x86_64
license = GPL3
depends = parted
- options = !buildflags
- options = !makeflags
- source = https://github.com/AltraMayor/f3/archive/v7.2.zip
- md5sums = 23026d5463e9ec2b36a00a42ec8f0d5f
+ source = f3-8.0.tar.gz::https://github.com/AltraMayor/f3/archive/v8.0.tar.gz
+ sha256sums = fb5e0f3b0e0b0bff2089a4ea6af53278804dfe0b87992499131445732e311ab4
pkgname = f3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
index c1b835f5b3a3..50526ee30a7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,27 @@
-# Maintainer: Kaio Augusto <kaioaugusto.8@gmail.com>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Kaio Augusto <kaioaugusto.8@gmail.com>
# Contributor: Kyle <kyle@free2.ml>
# Contributor: mib1982 <Mi.Bentlage@gmail.com>
# Contributor: z3ntu <luca.emanuel.weiss@gmail.com>
-pkgname=f3
-pkgver=7.2
+pkgname='f3'
+pkgver=8.0
pkgrel=1
-pkgdesc="Utilities to detect and repair counterfeit flash storage, i.e. thumb drives and memory cards with less flash than advertised"
-arch=('armv7h' 'aarch64' 'i686' 'x86_64')
-url="http://oss.digirati.com.br/f3/"
+pkgdesc='Simple tool that tests flash cards capacity and performance to see if they live up to claimed specifications'
+arch=('x86_64')
+url='https://github.com/AltraMayor/f3'
license=('GPL3')
depends=('parted')
-options=('!buildflags'
- '!makeflags')
-conflicts=()
-provides=()
-source=(https://github.com/AltraMayor/${pkgname}/archive/v${pkgver}.zip)
-md5sums=('23026d5463e9ec2b36a00a42ec8f0d5f')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('fb5e0f3b0e0b0bff2089a4ea6af53278804dfe0b87992499131445732e311ab4')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- sed -i -e 's:/usr/local:/usr:g' Makefile
- make
- make extra
+ make -C "${pkgname}-${pkgver}" {,extra}
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=$pkgdir install
- make DESTDIR=$pkgdir install-extra
+ make DESTDIR="${pkgdir}" PREFIX='/usr' -C "${pkgname}-${pkgver}" install{,-extra}
+ install -Dvm644 "${pkgname}-${pkgver}/README.rst" -t "${pkgdir}/usr/share/doc/${pkgname}"
}
+
+# vim: ts=2 sw=2 et: