summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjokersus2021-10-16 19:24:24 +0300
committerjokersus2021-10-16 19:24:24 +0300
commitb2c54872f45c9fa1b11fd9cf5dad6c51aec392dc (patch)
treecbd43a22705c104f0b2e58d05dc19fce303e01bf
downloadaur-b2c54872f45c9fa1b11fd9cf5dad6c51aec392dc.tar.gz
Init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8a1f2e1ec03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = f3d-bin
+ pkgdesc = A fast and minimalist 3D viewer
+ pkgver = 1.1.0
+ pkgrel = 1
+ epoch = 1
+ url = https://gitlab.kitware.com/${pkgname}/${pkgname}
+ arch = x86_64
+ license = BSD
+ provides = f3d
+ conflicts = f3d
+ source = https://gitlab.kitware.com/f3d/f3d/uploads/937b2b6c8a14b40538983195395b4094/f3d-1.1.0-Linux.tar.xz
+ sha256sums = 8a0968437463a1713e16be16216fe30fea5a34ae1546de6ceb5187effd96dbc1
+
+pkgname = f3d-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aef86510ce4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: jokersus <jokersus.cava@gmail.com>
+_pkgname=f3d
+pkgname=${_pkgname}-bin
+pkgver=1.1.0
+pkgrel=1
+epoch=1
+pkgdesc='A fast and minimalist 3D viewer'
+arch=('x86_64')
+url='https://gitlab.kitware.com/${pkgname}/${pkgname}'
+license=('BSD')
+provides=('f3d')
+conflicts=('f3d')
+source=("https://gitlab.kitware.com/f3d/f3d/uploads/937b2b6c8a14b40538983195395b4094/$_pkgname-$pkgver-Linux.tar.xz")
+sha256sums=('8a0968437463a1713e16be16216fe30fea5a34ae1546de6ceb5187effd96dbc1')
+
+package() {
+ cd "$_pkgname-$pkgver-Linux"
+ install -Dm755 "./bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ cp -r "./share" "${pkgdir}/usr/share/"
+} \ No newline at end of file