summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-01-27 16:05:41 +0100
committerXiretza2021-01-27 16:05:41 +0100
commit26e84ed1b5a9272ed3b45ced891164aa13585531 (patch)
treec4ec2e5db5f648b84c0b86b6eeca936a9a3b80f6
parent6e6ef95e50cc052f1c1a572bd72c4bc2e3aafcaa (diff)
downloadaur-26e84ed1b5a9272ed3b45ced891164aa13585531.tar.gz
Workaround symbiflow-examples#120: disable ABC9 in synth.tcl
https://github.com/SymbiFlow/symbiflow-examples/issues/120
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
-rw-r--r--synth.tcl-disable-abc9.patch13
3 files changed, 24 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d5b178869a3..0c1e78108b4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,7 @@ pkgbase = symbiflow-arch-defs-nightly-bin
noextract = fix_xc7_carry.py.patch
noextract = synth.tcl.patch
noextract = wrappers.patch
+ noextract = synth.tcl-disable-abc9.patch
noextract = symbiflow-arch-defs-install-bff52005.tar.xz
noextract = symbiflow-arch-defs-xc7a50t_test-bff52005.tar.xz
noextract = symbiflow-arch-defs-xc7a100t_test-bff52005.tar.xz
@@ -21,6 +22,7 @@ pkgbase = symbiflow-arch-defs-nightly-bin
source = fix_xc7_carry.py.patch
source = synth.tcl.patch
source = wrappers.patch
+ source = synth.tcl-disable-abc9.patch
source = https://storage.googleapis.com/symbiflow-arch-defs/artifacts/prod/foss-fpga-tools/symbiflow-arch-defs/continuous/install/125/20210122-000052/symbiflow-arch-defs-install-bff52005.tar.xz
source = https://storage.googleapis.com/symbiflow-arch-defs/artifacts/prod/foss-fpga-tools/symbiflow-arch-defs/continuous/install/125/20210122-000052/symbiflow-arch-defs-xc7a50t_test-bff52005.tar.xz
source = https://storage.googleapis.com/symbiflow-arch-defs/artifacts/prod/foss-fpga-tools/symbiflow-arch-defs/continuous/install/125/20210122-000052/symbiflow-arch-defs-xc7a100t_test-bff52005.tar.xz
@@ -31,6 +33,7 @@ pkgbase = symbiflow-arch-defs-nightly-bin
sha256sums = b6657ddbce1ba8ef0c24666223fefa758ced8619811608b9c4e89ce4904bb96f
sha256sums = 8102bbf8169e37e305f73515a3764d216daad725d20ad38f1e363990c9493b59
sha256sums = e3133a27e74cade311489ad5a51936dedd7384621b9f3c6d53da4423ea8fac78
+ sha256sums = 9822a26f45ac0bfa556f1f3d550aad03225802740c21d0fa8c750c2358a76e04
sha256sums = 6cdb158efca060706cb25f8f3610316a1a1f263cca74d84463736c00790d6d6d
sha256sums = dd2d5cb4ec59cc08a8f63a12ba4d8d76d046add90baac2f46bd8c74bf91c4d4f
sha256sums = 3f6e8c158e447c2bdaac6a7fc7b45557935ed1644a973d87213ff6faef1ff1b5
diff --git a/PKGBUILD b/PKGBUILD
index 997956167a92..087f2476d2e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,6 +19,7 @@ source=("https://raw.githubusercontent.com/SymbiFlow/$_pkgname/$_commit/COPYING"
"fix_xc7_carry.py.patch"
"synth.tcl.patch"
"wrappers.patch"
+ "synth.tcl-disable-abc9.patch"
"$_baseurl/$_pkgname-install-$_commit.tar.xz")
for _d in "${_devices[@]}"; do
source+=("$_baseurl/$_pkgname-${_d}_test-$_commit.tar.xz")
@@ -28,6 +29,7 @@ sha256sums=('0726ddf229165179fe21da0c97884eeddf88be32dcfc13abf9b2eced0dbafad6'
'b6657ddbce1ba8ef0c24666223fefa758ced8619811608b9c4e89ce4904bb96f'
'8102bbf8169e37e305f73515a3764d216daad725d20ad38f1e363990c9493b59'
'e3133a27e74cade311489ad5a51936dedd7384621b9f3c6d53da4423ea8fac78'
+ '9822a26f45ac0bfa556f1f3d550aad03225802740c21d0fa8c750c2358a76e04'
'6cdb158efca060706cb25f8f3610316a1a1f263cca74d84463736c00790d6d6d'
'dd2d5cb4ec59cc08a8f63a12ba4d8d76d046add90baac2f46bd8c74bf91c4d4f'
'3f6e8c158e447c2bdaac6a7fc7b45557935ed1644a973d87213ff6faef1ff1b5'
@@ -56,9 +58,13 @@ _package-toolchain() {
rm "$pkgdir/usr/environment.yml"
- patch -d "$pkgdir/usr/bin/" -p1 < "$srcdir/wrappers.patch"
+ # https://github.com/SymbiFlow/symbiflow-arch-defs/issues/1973, needs patch adjustment
+ [ ! -f "$pkgdir/usr/bin/symbiflow_write_xml_rr_graph" ]
+
+ patch --no-backup-if-mismatch -d "$pkgdir/usr/bin/" -p1 < "$srcdir/wrappers.patch"
patch -d "$pkgdir/usr/share/symbiflow/scripts/" -p1 < "$srcdir/fix_xc7_carry.py.patch"
- patch --fuzz=3 -d "$pkgdir/usr/share/symbiflow/scripts/xc7/" -p1 < "$srcdir/synth.tcl.patch"
+ patch -d "$pkgdir/usr/share/symbiflow/scripts/xc7/" -p1 < "$srcdir/synth.tcl.patch"
+ patch -d "$pkgdir/usr/share/symbiflow/scripts/xc7/" -p1 < "$srcdir/synth.tcl-disable-abc9.patch"
sed -i "s#source \"[^\"]*/env\"#source /usr/lib/$_pkgname/env#" "$pkgdir"/usr/bin/*
sed -i 's#SHARE_DIR_PATH=.*#SHARE_DIR_PATH=/usr/share/symbiflow/#' "$pkgdir/usr/bin/env"
diff --git a/synth.tcl-disable-abc9.patch b/synth.tcl-disable-abc9.patch
new file mode 100644
index 000000000000..7c42926bcf62
--- /dev/null
+++ b/synth.tcl-disable-abc9.patch
@@ -0,0 +1,13 @@
+diff --git a/synth.tcl b/synth.tcl
+index 1a73aa66..bd10d2cc 100644
+--- a/synth.tcl
++++ b/synth.tcl
+@@ -155,7 +155,7 @@ write_ilang $::env(OUT_JSON).pre_abc9.ilang
+ if { $::env(USE_ROI) == "TRUE" } {
+ synth_xilinx -flatten -abc9 -nosrl -noclkbuf -nodsp -noiopad -nowidelut -run map_ffs:check
+ } else {
+- synth_xilinx -flatten -abc9 -nosrl -noclkbuf -nodsp -iopad -nowidelut -run map_ffs:check
++ #synth_xilinx -flatten -abc9 -nosrl -noclkbuf -nodsp -iopad -nowidelut -run map_ffs:check
+ }
+
+ write_ilang $::env(OUT_JSON).post_abc9.ilang