summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach Hoffman2020-10-03 19:47:28 -0600
committerZach Hoffman2020-10-03 19:47:28 -0600
commit9705b462891ff58fea9f3dcda72d97a46b49f66a (patch)
tree4a985ccf1f37cb1268bdc7bc0e4aa68e25d841a3
parent2e816762b81093da4f0f7aed18233a865ed8f090 (diff)
downloadaur-9705b462891ff58fea9f3dcda72d97a46b49f66a.tar.gz
Update README.rst. Summary of changes:
- Update JavaScript code to get a connection URL for newer Webtop versions that do not expose snaGetLaunchLink(), dcl, etc. to the JavaScript global namespace - Add more alternatives
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--README.rst27
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c4fb3d92b12..c8609cd3fc7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = f5vpn
pkgdesc = VPN client using the Point-to-Point Protocol to connect to F5Networks BIG-IP APM 13.0
pkgver = 7183.2020.0108.1
- pkgrel = 2
+ pkgrel = 3
url = https://support.f5.com/csp/article/K32311645#link_04_05
arch = x86_64
license = commercial
@@ -15,7 +15,7 @@ pkgbase = f5vpn
md5sums = 130ef2376ad4581cc91a11814c00d948
sha256sums = a8f4b5d965dc0279dd5173109892251ce5d107d9912836e6d83a9b6896eb19a1
sha256sums = 3ecd8a10941a7d81b9d16aecdf6ac9caa1f957e32a2d2c65bde5181abd1fcb73
- source_x86_64 = linux_f5vpn-7183.2020.0108.1-2.x86_64.rpm::https://new.vpn.msu.edu/public/download/linux_f5vpn.x86_64.rpm
+ source_x86_64 = linux_f5vpn-7183.2020.0108.1-3.x86_64.rpm::https://new.vpn.msu.edu/public/download/linux_f5vpn.x86_64.rpm
md5sums_x86_64 = 475813581c09861c69e5e7376909e3bb
sha256sums_x86_64 = 5ce1e05a353e5a95c2fa5f7a4411c62c58a54dbd867630c5164aa46c5525e2a6
diff --git a/PKGBUILD b/PKGBUILD
index 4f75a536f974..43ff2b6cd17b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Zach Hoffman <zach@zrhoffman.net>
pkgname=f5vpn
pkgver=7183.2020.0108.1
-pkgrel=2
+pkgrel=3
pkgdesc='VPN client using the Point-to-Point Protocol to connect to F5Networks BIG-IP APM 13.0'
arch=('x86_64')
source=('LICENSE'
diff --git a/README.rst b/README.rst
index 1b1b218fd2df..a0a09b0c804a 100644
--- a/README.rst
+++ b/README.rst
@@ -8,13 +8,21 @@ Usage
1. In a web browser, go to `<https://[your-BIG-IP-APM-server]/>`_ and log in (including 2-factor authentication, if you use it).
-2. Open Developer Tools and run this JavaScript:
+2. Choose Web Network Access. If this works for you, the following steps do not apply to you.
+ If you prefer connecting in the command line, open Developer Tools and run this JavaScript:
- .. code-block:: javascript
+ .. code-block:: javascript
- snaGetLaunchLink('network_access', dcl.getBins[0].res.reduce((result, bin) => bin.type === 'network_access' ? bin.id : result, {}))['link']
+ xhr = new XMLHttpRequest();
+ resourceType = "network_access";
+ with (xhr) {
+ responseType = "document";
+ open("GET", `https://${location.host}:${location.port}/vdesk/resource_list.xml?resourcetype=res`);
+ onload = () => console.log(`f5-vpn://${location.host}:${location.port}/?server=${location.host}&resourcename=${responseXML.querySelector(`list[type=${resourceType}] entry`).textContent}&resourcetype=${resourceType}&cmd=launch&protocol=https&port=${location.port || 443}&sid=${document.cookie.match(/MRHSession=(.*?); /)[1]}`);
+ send();
+ }
- You should have received a URL starting with ``f5-vpn://``.
+ You should have received a URL starting with ``f5-vpn://``.
3. In a terminal, run ``f5vpn`` using the URL from Step 2 as its argument (including single quotes):
@@ -24,12 +32,11 @@ Usage
If everything worked, the GUI for F5 VPN should be visible. Assuming continuous Internet connectivity, you should remain connected for several hours.
-Known Bugs
-----------
+CLI-Only Alternatives
+---------------------
-If you resize the window, it disconnects. If that happens, you can re-run the ``f5vpn`` command with the same URL as before.
+* `kayrus/gof5 <https://github.com/kayrus/gof5>`_ (FOSS)
-Open Source Alternatives
-------------------------
+* `zrhoffman/svpn-login <https://github.com/zrhoffman/svpn-login>`_
-* `zrhoffman/f5vpn-login <https://github.com/zrhoffman/f5vpn-login>`_
+* `zrhoffman/f5vpn-login <https://github.com/zrhoffman/f5vpn-login>`_ (FOSS, very slow)