summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach Hoffman2023-08-14 12:07:15 -0600
committerZach Hoffman2023-08-14 12:07:15 -0600
commitbdae8725affa0f904c0488a179f21928ddb06d50 (patch)
tree9c66cb91a5c2db8588ab350dd60e0aebbf23933e
parent97a078acd0d264db6c53162069ab0a613f535a26 (diff)
downloadaur-bdae8725affa0f904c0488a179f21928ddb06d50.tar.gz
Faster mirror for 7243.2023.0720.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--README.rst4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac2215b66448..7761caf11dd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = f5vpn
pkgdesc = VPN client using the Point-to-Point Protocol to connect to F5Networks BIG-IP APM
pkgver = 7243.2023.0720.1
- pkgrel = 3
+ pkgrel = 4
url = https://support.f5.com/csp/article/K32311645#link_04_05
arch = x86_64
license = commercial
@@ -16,7 +16,7 @@ pkgbase = f5vpn
sha512sums = 51ee6ca353685de98b5e87bf44de9605006190cc56ae4612c39f9f4e8b22d89b5bfab6cba09b740bb799fa74ce3a8054c533f807473b13c2c4da3683da4fef4c
b2sums = c864e69799ffc4c13bf8af7d76bcc8beed195d9a41acb01d459aaa0c3cd5bae75290ef7be1fa6a0bfd6472e1c3f8df3a7f5d59767861ded0dc4a373a3ead447c
b2sums = 5be3f5ebd0358e022c85081b45bc23b1e847542ae9035bece95c40fa5113a1fd9159ced013950d237206c2e6be94caa38b9d6414ea29ab65cd80043a2dfbfe5a
- source_x86_64 = linux_f5vpn-7243.2023.0720.1-3.x86_64.rpm::https://vpn.univie.ac.at/public/download/linux_f5vpn.x86_64.rpm
+ source_x86_64 = linux_f5vpn-7243.2023.0720.1-4.x86_64.rpm::https://connect.healthsystem.virginia.edu/public/download/linux_f5vpn.x86_64.rpm
sha512sums_x86_64 = ce3b65b12e9721c5acd6b97ff271b58e3769a31df1d9c9dc0c846c29a390a19f901792660595b4898d39f5d00f477dc2e3dc2d92a9dff0211999a3f5f5d4aa48
b2sums_x86_64 = ac4c8f0538773d8e9e363eba8c226078af6cb92cc546748cdb81a3e9bd38c50cc4fc65b7e2bdb9c742eef0d61d36e4a65077751b65eadf6abb0f8d822447893a
diff --git a/PKGBUILD b/PKGBUILD
index 14bdb482f5a8..079df9500fa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Zach Hoffman <zrhoffman@apache.org>
pkgname=f5vpn
pkgver=7243.2023.0720.1
-pkgrel=3
+pkgrel=4
pkgdesc='VPN client using the Point-to-Point Protocol to connect to F5Networks BIG-IP APM'
arch=('x86_64')
-mirror=vpn.univie.ac.at
+mirror=connect.healthsystem.virginia.edu
source=('LICENSE'
'no-desktop-file-dbus.patch')
source_x86_64=("linux_${pkgname}-${pkgver}-${pkgrel}.${CARCH}.rpm::https://${mirror}/public/download/linux_${pkgname}.${CARCH}.rpm")
diff --git a/README.rst b/README.rst
index f124dfe43d6b..b73e2a0111bb 100644
--- a/README.rst
+++ b/README.rst
@@ -9,14 +9,14 @@ Usage
1. In a web browser, go to `<https://[your-BIG-IP-APM-server]/>`_ and log in (including 2-factor authentication, if you use it).
2. Choose Web Network Access. If this works for you, the following steps do not apply to you.
- If you prefer connecting in the command line, open Developer Tools and run this JavaScript:
+ If you prefer connecting from the command line, open Developer Tools and run this JavaScript:
.. code-block:: javascript
resourceType = "network_access";
with (new XMLHttpRequest()) {
open("GET", `https://${location.host}:${location.port}/vdesk/resource_list.xml?resourcetype=res`);
- onload = () => console.log(`f5-vpn://${location.host}:${location.port}/?server=${location.host}&resourcename=${responseXML.querySelector(`list[type=${resourceType}] entry`).textContent}&resourcetype=${resourceType}&cmd=launch&protocol=https&port=${location.port || 443}&sid=${document.cookie.match(/MRHSession=(.*?); /)[1]}`);
+ onload = () => console.log(`f5-vpn://${location.host}:${location.port || 443}/?server=${location.host}&resourcename=${responseXML.querySelector(`list[type=${resourceType}] entry`).textContent}&resourcetype=${resourceType}&cmd=launch&protocol=https&port=${location.port || 443}&sid=${document.cookie.match(/MRHSession=(.*?); /)[1]}`);
send();
}