summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Griffin2008-04-06 01:17:02 +0000
committerAaron Griffin2008-04-06 01:17:02 +0000
commitdf13150a12f8d954caf17c74cf121d083d25ad3e (patch)
treed735625e2bc607e01f820eccb7c4fa1d2e4c11ec
downloadaur-df13150a12f8d954caf17c74cf121d083d25ad3e.tar.gz
Initial import of all packages
-rw-r--r--PKGBUILD28
-rw-r--r--libmp4v2.patch11
-rw-r--r--pipe-output.patch18
3 files changed, 57 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6af7eaff3443
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD,v 1.11 2008/02/01 16:46:17 alexander Exp $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Sarah Hay <sarah@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+pkgname=faac
+pkgver=1.26
+pkgrel=1
+pkgdesc="FAAC is an AAC audio encoder."
+arch=(i686 x86_64)
+url="http://www.audiocoding.com/"
+license=('GPL' 'custom')
+depends=('libmp4v2' 'glibc')
+makedepends=('automake' 'autoconf' 'libtool')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+
+build() {
+ cd ${startdir}/src/${pkgname}
+ find . -type f -print0 | xargs -0 sed -i 's/\r//g'
+ ./bootstrap
+ ./configure --prefix=/usr --with-mp4v2
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+
+ install -D -m644 ${startdir}/src/${pkgname}/libfaac/kiss_fft/COPYING \
+ ${startdir}/pkg/usr/share/licenses/faac/COPYING.kiss_fft
+}
+md5sums=('1d7c019bd2dbb4f3101b8937ebc59cf6')
diff --git a/libmp4v2.patch b/libmp4v2.patch
new file mode 100644
index 000000000000..b2c01656d9b5
--- /dev/null
+++ b/libmp4v2.patch
@@ -0,0 +1,11 @@
+--- faac/configure.in 2006-08-13 14:17:26.000000000 +0000
++++ faac-patched/configure.in 2007-01-29 19:18:45.000000000 +0000
+@@ -35,6 +35,8 @@
+
+ if test x$external_mp4v2 = xyes; then
+ AC_MSG_NOTICE([*** Building with external mp4v2 ***])
++ MY_DEFINE(HAVE_LIBMP4V2)
++ LIBS="-lmp4v2 $LIBS"
+ else
+ if test x$WITHMP4V2 = xyes; then
+ AC_MSG_NOTICE([*** Building with internal mp4v2 ***])
diff --git a/pipe-output.patch b/pipe-output.patch
new file mode 100644
index 000000000000..a8581f392273
--- /dev/null
+++ b/pipe-output.patch
@@ -0,0 +1,18 @@
+--- faac/frontend/main.c 2004-12-08 11:07:17.000000000 +0000
++++ faac-patched/frontend/main.c 2007-01-29 19:17:26.000000000 +0000
+@@ -918,7 +918,14 @@
+ {
+ #endif
+ /* open the aac output file */
+- outfile = fopen(aacFileName, "wb");
++ if (aacFileName[0] == '-')
++ {
++ outfile = stdout;
++ }
++ else
++ {
++ outfile = fopen(aacFileName, "wb");
++ }
+ if (!outfile)
+ {
+ fprintf(stderr, "Couldn't create output file %s\n", aacFileName);