summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxduugu2018-08-07 13:59:25 +0200
committerxduugu2018-08-07 13:59:25 +0200
commit8af4ad5cfdd55b1524c7bfcea7bbaaffb5225a2f (patch)
treea25b49d7f813b32374e896dc2932373e72aaf8c9
parente03e049fab6616450f28f2ea9e0cd28975180016 (diff)
downloadaur-8af4ad5cfdd55b1524c7bfcea7bbaaffb5225a2f.tar.gz
Update to 4.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e75689a87980..812c5bfc452d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = faba-icon-theme
pkgdesc = A sexy and modern icon theme with Tango influences.
- pkgver = 4.1.2
+ pkgver = 4.3
pkgrel = 1
- url = https://snwh.org/moka
+ url = https://snwh.org/moka#faba-icon-theme
arch = any
license = LGPL3
license = CCPL-4.0:by-sa
+ makedepends = meson
depends = gtk-update-icon-cache
- source = faba-icon-theme-4.1.2.tar.gz::https://github.com/moka-project/faba-icon-theme/archive/v4.1.2.tar.gz
- md5sums = 7966a99b8e9098e2474655229093e08c
- sha512sums = fd11e0aa1ab3e57ec2bde29a493dd58922759080291e7bd91b53d1395984a33e1e82da606d8e08fd8ce16e82f3709e90b12e5592261e2e450ad54d2a43d49fe4
+ options = !strip
+ source = faba-icon-theme-4.3.tar.gz::https://github.com/moka-project/faba-icon-theme/archive/v4.3.tar.gz
+ md5sums = 34633c7d146b93abebc96d3dddd52053
+ sha512sums = eb86df4675d42c67a348466270640b93dde2a93304111a93205c7f1af06a677788d9f1a5bcacabdb60cc1ce9da4b49f29a3c5039109be40fc180cf4fea3f7d1b
pkgname = faba-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index 3df8fb9cb1e7..2236d1b156bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
pkgname=faba-icon-theme
-pkgver=4.1.2
+pkgver=4.3
pkgrel=1
pkgdesc="A sexy and modern icon theme with Tango influences."
arch=('any')
-url="https://snwh.org/moka"
+url="https://snwh.org/moka#faba-icon-theme"
license=('LGPL3' 'CCPL-4.0:by-sa')
depends=('gtk-update-icon-cache')
+makedepends=('meson')
+options=('!strip')
source=("$pkgname-$pkgver.tar.gz::https://github.com/moka-project/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('7966a99b8e9098e2474655229093e08c')
-sha512sums=('fd11e0aa1ab3e57ec2bde29a493dd58922759080291e7bd91b53d1395984a33e1e82da606d8e08fd8ce16e82f3709e90b12e5592261e2e450ad54d2a43d49fe4')
+md5sums=('34633c7d146b93abebc96d3dddd52053')
+sha512sums=('eb86df4675d42c67a348466270640b93dde2a93304111a93205c7f1af06a677788d9f1a5bcacabdb60cc1ce9da4b49f29a3c5039109be40fc180cf4fea3f7d1b')
build() {
cd "$pkgname-$pkgver"
- bash autogen.sh
- make
+ arch-meson . build
+ ninja -C build
}
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" ninja -C build install
}