summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2020-10-19 00:17:32 +0200
committerAlad Wenter2020-10-19 00:17:32 +0200
commitf067529becaecfb8c91fcf1813ec0e5fa66f360e (patch)
tree28f2fe91c2f0abe1cb305df157b7bb1735f40ab1
parent8af4ad5cfdd55b1524c7bfcea7bbaaffb5225a2f (diff)
downloadaur-f067529becaecfb8c91fcf1813ec0e5fa66f360e.tar.gz
Import from community
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 812c5bfc452d..c7e1890f8147 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = faba-icon-theme
- pkgdesc = A sexy and modern icon theme with Tango influences.
+ pkgdesc = A set of icons to serve as base for other themes
pkgver = 4.3
- pkgrel = 1
- url = https://snwh.org/moka#faba-icon-theme
+ pkgrel = 2
+ url = https://snwh.org/moka
arch = any
license = LGPL3
- license = CCPL-4.0:by-sa
+ license = CCPL
makedepends = meson
depends = gtk-update-icon-cache
options = !strip
source = faba-icon-theme-4.3.tar.gz::https://github.com/moka-project/faba-icon-theme/archive/v4.3.tar.gz
md5sums = 34633c7d146b93abebc96d3dddd52053
- sha512sums = eb86df4675d42c67a348466270640b93dde2a93304111a93205c7f1af06a677788d9f1a5bcacabdb60cc1ce9da4b49f29a3c5039109be40fc180cf4fea3f7d1b
pkgname = faba-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index 2236d1b156bc..18b8ed019450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
+# Maintainer: Alad Wenter <alad@archlinux.org>
+# Contributor: xduugu <xduugu@gmx.com>
pkgname=faba-icon-theme
pkgver=4.3
-pkgrel=1
-pkgdesc="A sexy and modern icon theme with Tango influences."
+pkgrel=2
+pkgdesc="A set of icons to serve as base for other themes"
arch=('any')
-url="https://snwh.org/moka#faba-icon-theme"
-license=('LGPL3' 'CCPL-4.0:by-sa')
+url='https://snwh.org/moka'
+license=('LGPL3' 'CCPL')
depends=('gtk-update-icon-cache')
makedepends=('meson')
options=('!strip')
source=("$pkgname-$pkgver.tar.gz::https://github.com/moka-project/$pkgname/archive/v$pkgver.tar.gz")
md5sums=('34633c7d146b93abebc96d3dddd52053')
-sha512sums=('eb86df4675d42c67a348466270640b93dde2a93304111a93205c7f1af06a677788d9f1a5bcacabdb60cc1ce9da4b49f29a3c5039109be40fc180cf4fea3f7d1b')
build() {
- cd "$pkgname-$pkgver"
- arch-meson . build
- ninja -C build
+ meson --prefix /usr --buildtype plain "$pkgname-$pkgver" build
+ ninja -C build
}
package() {
- cd "$pkgname-$pkgver"
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" ninja -C build install
}