summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Fung2021-12-19 01:55:37 -0800
committerEric Fung2021-12-19 01:55:37 -0800
commit0f9e222e47bf23efaf0d68b085bef93c5fc3aa63 (patch)
tree7381b270b778498b6a676f0c73dd27e2972f222c
parent7f177df6e6efd0419090ee998e696d2f3c01231b (diff)
downloadaur-0f9e222e47bf23efaf0d68b085bef93c5fc3aa63.tar.gz
Updated PKGBUID with upstream build instructions
-rw-r--r--.SRCINFO12
-rw-r--r--[-rwxr-xr-x]PKGBUILD30
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0607e116960c..d9e9fa49b5ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = faba-mono-icons-git
- pkgdesc = The monochromatic panel icon sets for Faba.
- pkgver = 94.560b521
+ pkgdesc = Supplementary theme to Faba Icon Theme - consists only of monochrome panel icons
+ pkgver = r106.2006c52
pkgrel = 1
- url = http://mokaproject.com/faba-icon-theme/
+ url = https://snwh.org/moka
install = faba-mono-icons.install
arch = any
license = GPL3
makedepends = git
- depends = faba-icon-theme-git
+ depends = faba-icon-theme
depends = gtk-update-icon-cache
provides = faba-mono-icons
conflicts = faba-mono-icons
- replaces = faba-mono-icons
options = !strip
- source = faba-mono-icons::git+https://github.com/moka-project/faba-mono-icons.git
+ source = git+https://github.com/snwh/faba-mono-icons.git
sha256sums = SKIP
pkgname = faba-mono-icons-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8a900c6637aa..902b64728520 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: Martin Wimpress <code@flexion.org>
-_pkgname=faba-mono-icons
-pkgname=${_pkgname}-git
-pkgver=94.560b521
+pkgname=faba-mono-icons-git
+_pkgname=${pkgname%-git}
+pkgver=r106.2006c52
pkgrel=1
-pkgdesc="The monochromatic panel icon sets for Faba."
+pkgdesc="Supplementary theme to Faba Icon Theme - consists only of monochrome panel icons"
arch=('any')
-url="http://mokaproject.com/faba-icon-theme/"
+url="https://snwh.org/moka"
license=('GPL3')
-depends=('faba-icon-theme-git' 'gtk-update-icon-cache')
+depends=('faba-icon-theme' 'gtk-update-icon-cache')
makedepends=('git')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-replaces=("${_pkgname}")
options=(!strip)
-source=(${_pkgname}::"git+https://github.com/moka-project/${_pkgname}.git")
+source=("git+https://github.com/snwh/${_pkgname}.git")
sha256sums=('SKIP')
install=${_pkgname}.install
pkgver() {
- cd ${srcdir}/${_pkgname}
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh
}
package() {
- install -d -m 755 "${pkgdir}"/usr/share/icons/{Faba-Mono,Faba-Mono-Dark}
- cp -dr --no-preserve=ownership "${_pkgname}"/{Faba-Mono,Faba-Mono-Dark} "${pkgdir}"/usr/share/icons/
- find "${pkgdir}"/usr/share/icons/ -type d -exec chmod 755 {} \;
- find "${pkgdir}"/usr/share/icons/ -type f -exec chmod 644 {} \;
+ cd "${srcdir}/${_pkgname}"
+ DESTDIR="${pkgdir}" make install
}