summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-02-14 01:26:20 +0100
committerCarsten Teibes2014-02-14 01:26:20 +0100
commitf1e69fbd0ab4ca96fd0099a60a966a4e0021aff1 (patch)
treed43fe678a051b8a611a85b4bbfaf1c11073b3744
downloadaur-f1e69fbd0ab4ca96fd0099a60a966a4e0021aff1.tar.gz
[add] fabother-world-git
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD50
-rw-r--r--fabother-world.desktop8
-rw-r--r--fabother-world.install9
-rw-r--r--fabother-world.pngbin0 -> 3731 bytes
-rw-r--r--fabother-world.sh7
6 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a6d27d09654
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = fabother-world-git
+ pkgdesc = An interpreter for Another World (Out of this world)
+ pkgver = r62.0b0f404
+ pkgrel = 1
+ url = http://fabiensanglard.net/anotherWorld_code_review/
+ install = fabother-world.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = sh
+ depends = sdl
+ depends = zlib
+ provides = fabother-world
+ conflicts = fabother-world
+ source = fabother-world::git+https://github.com/fabiensanglard/Another-World-Bytecode-Interpreter.git
+ source = fabother-world.sh
+ source = fabother-world.png
+ source = fabother-world.desktop
+ sha256sums = SKIP
+ sha256sums = edc27018901b0d72fdeae797643070dbfa53dc2220d9f96af059b1aff4430aa9
+ sha256sums = b57c493f1ae135ebc2b809211db091957fa0a7b755856ef1637e58cdd7dd216e
+ sha256sums = 897a8ae9f3bf64e44dea5981b0d1189ea80e4aedf0b4ab039b7e969c7eb7593f
+
+pkgname = fabother-world-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58ee07c090d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+
+_pkgbase=fabother-world
+pkgname=$_pkgbase-git
+pkgver=r62.0b0f404
+pkgrel=1
+pkgdesc='An interpreter for Another World (Out of this world)'
+arch=('i686' 'x86_64')
+url="http://fabiensanglard.net/anotherWorld_code_review/"
+license=('GPL2')
+depends=('sh' 'sdl' 'zlib')
+makedepends=('git')
+conflicts=("$_pkgbase")
+provides=("$_pkgbase")
+install=$_pkgbase.install
+source=($_pkgbase::"git+https://github.com/fabiensanglard/Another-World-Bytecode-Interpreter.git"
+ "$_pkgbase.sh" "$_pkgbase.png" "$_pkgbase.desktop")
+sha256sums=('SKIP'
+ 'edc27018901b0d72fdeae797643070dbfa53dc2220d9f96af059b1aff4430aa9'
+ 'b57c493f1ae135ebc2b809211db091957fa0a7b755856ef1637e58cdd7dd216e'
+ '897a8ae9f3bf64e44dea5981b0d1189ea80e4aedf0b4ab039b7e969c7eb7593f')
+
+pkgver() {
+ cd $_pkgbase
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ # add our cxxflags
+ sed "s|CXXFLAGS.*DEFINES)$|& ${CXXFLAGS}|" -i $_pkgbase/Makefile
+}
+
+build() {
+ make -C $_pkgbase
+}
+
+package() {
+ cd $_pkgbase
+
+ # launcher + binary
+ install -Dm755 ../$_pkgbase.sh "$pkgdir"/usr/bin/$_pkgbase
+ install -Dm755 game "$pkgdir"/usr/share/$_pkgbase/$_pkgbase
+ # doc
+ install -Dm644 README "$pkgdir"/usr/share/doc/$_pkgbase/README
+ install -m644 README.newraw "$pkgdir"/usr/share/doc/$_pkgbase
+ tail -n 210 main.cpp > "$pkgdir"/usr/share/doc/$_pkgbase/implementation.txt
+ # desktop entry
+ install -Dm644 ../$_pkgbase.png "$pkgdir"/usr/share/pixmaps/$_pkgbase.png
+ install -Dm644 ../$_pkgbase.desktop "$pkgdir"/usr/share/applications/$_pkgbase.desktop
+}
diff --git a/fabother-world.desktop b/fabother-world.desktop
new file mode 100644
index 000000000000..5f0e95a227b1
--- /dev/null
+++ b/fabother-world.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Fabother World
+Comment=Another World (Out Of This World) interpreter
+Exec=fabother-world
+Icon=fabother-world
+Terminal=false
+Categories=Game;
diff --git a/fabother-world.install b/fabother-world.install
new file mode 100644
index 000000000000..a59b5de3ca3e
--- /dev/null
+++ b/fabother-world.install
@@ -0,0 +1,9 @@
+
+post_install() {
+ echo "You need the original 'Another World'/'Out of this World' data files to play."
+ echo "It searches for 'BANK*' and 'MEMLIST.BIN' in '~/.fabother-world/data'."
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/fabother-world.png b/fabother-world.png
new file mode 100644
index 000000000000..2b9a3bd54762
--- /dev/null
+++ b/fabother-world.png
Binary files differ
diff --git a/fabother-world.sh b/fabother-world.sh
new file mode 100644
index 000000000000..df5e46a0fd86
--- /dev/null
+++ b/fabother-world.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+mkdir -p ~/.fabother-world/data
+
+exec /usr/share/fabother-world/fabother-world \
+ --datapath=$HOME/.fabother-world/data \
+ --savepath=$HOME/.fabother-world "$@"