summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Wilms2020-11-08 12:20:58 +0100
committerKevin Wilms2020-11-08 12:20:58 +0100
commit2c89cfb251d5590694ad080457a4ea27a0a13187 (patch)
tree6369b79ecb428a4cb532d73f8be888fb98509d2c
downloadaur-2c89cfb251d5590694ad080457a4ea27a0a13187.tar.gz
First Build of Facebook-Desktop-App
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
-rw-r--r--facebook-desktop-app.desktop10
-rw-r--r--facebook-desktop-app.pngbin0 -> 9063 bytes
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1040d0025e36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = facebook-desktop-app
+ pkgdesc = Facebook Desktop built with nativefier (electron)
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.facebook.com
+ arch = armv7l
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = imagemagick
+ makedepends = nodejs-nativefier
+ depends = gtk3
+ depends = libxss
+ depends = nss
+ optdepends = libindicator-gtk3
+ source = facebook-desktop-app.png
+ source = facebook-desktop-app.desktop
+ sha256sums = dad893597cee2d49406c054380f9c338d1838db41083896ded6ccc6f26d8ef6a
+ sha256sums = d8e85271691a7f23fcfa7cb04b6435da4c7b0707644fddef9339ae15466e51a7
+
+pkgname = facebook-desktop-app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..521169a389f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: NobodyDBG <niemandausduisburg@gmx.net>
+
+pkgname=facebook-desktop-app
+pkgver=1.0
+pkgrel=1
+pkgdesc="Facebook Desktop built with nativefier (electron)"
+arch=("armv7l" "i686" "x86_64")
+url="https://www.facebook.com"
+license=("custom")
+depends=("gtk3" "libxss" "nss")
+optdepends=("libindicator-gtk3")
+makedepends=("imagemagick" "nodejs-nativefier")
+source=(
+ "${pkgname}.png"
+ "${pkgname}.desktop")
+sha256sums=(
+ "dad893597cee2d49406c054380f9c338d1838db41083896ded6ccc6f26d8ef6a"
+ "d8e85271691a7f23fcfa7cb04b6435da4c7b0707644fddef9339ae15466e51a7"
+)
+
+build() {
+ cd "${srcdir}"
+
+ nativefier \
+ --name "Facebook-Desktop-App" \
+ --icon "${pkgname}.png" \
+ --width "1280px" \
+ --height "1024px" \
+ --verbose \
+ --single-instance \
+ --tray \
+ "https://www.facebook.com"
+}
+
+package() {
+ install -dm755 "${pkgdir}/"{opt,usr/{bin,share/{applications,licenses/${pkgname}}}}
+
+ cp -rL "${srcdir}/${pkgname}-linux-x64"* "${pkgdir}/opt/${pkgname}"
+ ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${pkgdir}/opt/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ for _size in "192x192" "128x128" "96x96" "64x64" "48x48" "32x32" "24x24" "22x22" "20x20" "16x16" "8x8"
+ do
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/${_size}/apps"
+ convert "${srcdir}/${pkgname}.png" -resize "${_size}" "${pkgdir}/usr/share/icons/hicolor/${_size}/apps/${pkgname}.png"
+ done
+}
diff --git a/facebook-desktop-app.desktop b/facebook-desktop-app.desktop
new file mode 100644
index 000000000000..b8619cefff46
--- /dev/null
+++ b/facebook-desktop-app.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Facebook Desktop App
+Comment="Facebook Desktop built with nativefier (electron)"
+Exec=Facebook-Desktop-App
+Icon=Facebook-Desktop-App
+Encoding=UTF-8
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=Network;Chat;InstantMessaging;Application;
diff --git a/facebook-desktop-app.png b/facebook-desktop-app.png
new file mode 100644
index 000000000000..c229160e55e7
--- /dev/null
+++ b/facebook-desktop-app.png
Binary files differ