summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Kubica2010-07-15 13:37:30 +0200
committerMarek Kubica2010-07-15 13:37:30 +0200
commit240831e602beb75b754e3210defb4d4a7262d441 (patch)
treed02d9a33ba43186f6784e5274de0c28ea9af0c41
downloadaur-240831e602beb75b754e3210defb4d4a7262d441.tar.gz
Added the files from version 0.93-2
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD50
-rw-r--r--factor-vm2
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8cf721c8aaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = factor
+ pkgdesc = Factor is a general purpose, dynamically typed, stack-based programming language.
+ pkgver = 0.93
+ pkgrel = 1
+ url = http://factorcode.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = pango
+ depends = cairo
+ depends = glib2
+ depends = freetype2
+ depends = mesa
+ depends = libgl
+ provides = factor
+ conflicts = factor-git
+ options = !strip
+ source = http://downloads.factorcode.org/releases/0.93/factor-src-0.93.zip
+ source = factor-vm
+ md5sums = d5507d193e3b8c22e4d0be1a4a213934
+ md5sums = 172985592832c63157888bce652c273c
+
+pkgname = factor
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eea57cb5d148
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.swp
+*.tar.gz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eb8ea636db0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Leonidas <marek@xivilization.net>
+pkgname=factor
+pkgver=0.93
+pkgrel=1
+pkgdesc="Factor is a general purpose, dynamically typed, stack-based programming language."
+arch=(i686 x86_64)
+url="http://factorcode.org"
+license=(BSD)
+provides=(factor)
+conflicts=(factor-git)
+depends=(pango cairo glib2 freetype2 mesa libgl)
+options=(!strip)
+source=(http://downloads.factorcode.org/releases/$pkgver/$pkgname-src-$pkgver.zip
+ factor-vm)
+md5sums=('d5507d193e3b8c22e4d0be1a4a213934'
+ '172985592832c63157888bce652c273c')
+
+build() {
+ # thanks to qx from #concatenative for the proper SSE settings:
+ # i686: no SSE, x87 floating point
+ # x86_64: SSE2
+ _bootimg="boot.unix-x86.32.image"
+ _sseversion=0
+ [ $CARCH = x86_64 ] && _bootimg="boot.unix-x86.64.image" && _sseversion=20
+
+ cd $srcdir/$pkgname
+ # build the VM
+ make || return 1
+ # bootstrap factor with the minimum supported SSE
+ #./factor -i=$_bootimg -sse-version=$_sseversion
+
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/lib/factor
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname/
+
+ # copy over the stdlib
+ cp -a misc extra core basis factor.image $pkgdir/usr/lib/factor/
+ # make folders r+x and files r
+ chmod -R 0755 $pkgdir/usr/lib/factor
+ find $pkgdir/usr/lib/factor -type f -exec chmod -x {} \;
+
+ # copy over the actual binary
+ cp -a factor $pkgdir/usr/bin/factor-bin
+ # copy over the wrapper that calls factor with the proper image
+ cp $srcdir/factor-vm $pkgdir/usr/bin/factor-vm
+ chmod +x $pkgdir/usr/bin/factor-vm
+ # copy over the license (as defined in Arch Packaging Standards)
+ chmod -x license.txt
+ cp license.txt $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
diff --git a/factor-vm b/factor-vm
new file mode 100644
index 000000000000..b63e0d683bb9
--- /dev/null
+++ b/factor-vm
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec factor-bin -i=/usr/lib/factor/factor.image $@