summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastien Duthil2015-08-20 18:54:16 -0400
committerSebastien Duthil2015-08-20 18:54:16 -0400
commitb4976b2f3bed68af636908087d2d2f58c04c14b9 (patch)
tree43031e338febf5ac30a195b2116051aad196f31a
downloadaur-b4976b2f3bed68af636908087d2d2f58c04c14b9.tar.gz
Initial commit: 0.11.22-3
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE52
-rw-r--r--PKGBUILD68
-rw-r--r--factorio.desktop9
4 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa962c36c851
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = factorio
+ pkgdesc = A 2D game about building and maintaining factories.
+ pkgver = 0.11.22
+ pkgrel = 3
+ url = http://www.factorio.com/
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ depends = libxcursor
+ depends = alsa-lib
+ depends = libxrandr
+ depends = libxinerama
+ depends = mesa
+ conflicts = factorio-demo
+ source = factorio.desktop
+ source = LICENSE
+ md5sums = 5cacd198a3156c157a482aeab368e9a1
+ md5sums = 22fce67d66c080fa5c89ab437b3d8724
+
+pkgname = factorio
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2aedcc7d3535
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,52 @@
+# Source: http://www.factorio.com/terms-of-service
+
+Terms of Service
+
+The basic rule is: Use common sense. We try to be reasonable, please be too.
+The Game
+
+ Factorio is in an alpha stage of the development. That means it is an unfinished product so it may contain bugs and unfinished features.
+ The game is still evolving and is subject to changes in the future.
+ We are not liable for any damage that might be caused to you by downloading, installing and using our software.
+ Especially we are not responsible if you stay awake all night long playing Factorio and can't go to school / work in the morning:)
+ You download, install and use Factorio at your own risk.
+ There's always the possibility of a project being discontinued at any time.
+
+Paid content
+
+ Factorio demo is available to anyone free of charge.
+ All the content listed on our preorder page is paid. This includes, but is not limited to the alpha version of the game, the wallpapers, the scenario packs, the concept art book, etc.
+ You get access to our paid content by buying the appropriate type of the account.
+ Possesion of the account entitles you to all the updates to the digital content associated with this account for free in the future. For instance the lowest tier membership (Transport Belt Repair Man) will receive all the updates to the core game itself in the future.
+ The contents and the price of particular tiers are subject to change in the future. We reserve the right to change the tier prices and add content when we feel it is appropriate.
+
+Purchase and Refunds
+
+ After the purchase you will receive an electronic invoice from our payment processing service.
+ After the purchase you will also receive a confirmation email from us with the upgrade code to your new tier and instructions on how to use it.
+ There are no additional or hidden fees. You pay once for the product (the membership tier) and that is it.
+ If you would like to cancel the purchase (i.e. when the game is not working) then please contact us by email at support@factorio.com.
+
+Intellectual Property and Sharing
+
+ You may use Factorio and other paid content for your own personal use.
+ All the content in the game is owned by us. This includes the user provided content that makes it into the game as well (for instance namely translations).
+ Don't sell, copy, transfer or distribute the game, its hacked / altered version, any of its parts or any of our paid content.
+ Ask us for approval to use the game, any of its parts or any materials on our website for any commercial purpose.
+ We encourage users to mod the game within the reasonable boundaries. This includes writing own Lua levels, creating own texture packs, changing properties in the JSON files, etc.
+
+Use of service
+
+ Children may use an account established by their parent or legal guardian with the approval of such a person.
+ The game doesn't contain explicit violence and we believe it is appropriate for children from 12 years.
+ If you wish to cancel your account please send us an email to support@factorio.com.
+ We reserve the right to suspend accounts of users that will clearly violate the terms of service or our privacy policy. In such a case we will first try to resolve the situation by communicating with the user. Suspending the account is the last resort.
+
+Other
+
+ Don't do anything that could harm the development of the game or its distribution.
+ The materials appearing on Factorio's website may include technical or typographical errors. We don't warrant that any of the materials on its website are complete, accurate or current
+ There are couple of places where you can share ideas and opinions with other players (our Forum, Twitter, Facebook page). Please behave there appropriately and don’t do anything that gets us into troubles.
+ In case of legal dispute, the governing laws of the Czech Republic will apply.
+
+We reserve the right to update these terms at any point in time with immediate effect. Last update was on 8th of April 2014.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32bbfe6f3bfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Sebastien Duthil <duthils@free.fr>
+
+pkgname=factorio
+pkgver=0.11.22
+pkgrel=3
+pkgdesc="A 2D game about building and maintaining factories."
+arch=('i686' 'x86_64')
+url="http://www.factorio.com/"
+license=('custom: commercial')
+conflicts=('factorio-demo')
+depends=('libxcursor' 'alsa-lib' 'libxrandr' 'libxinerama' 'mesa')
+source=(factorio.desktop
+ LICENSE)
+md5sums=('5cacd198a3156c157a482aeab368e9a1'
+ '22fce67d66c080fa5c89ab437b3d8724')
+if test "$CARCH" == i686; then
+ __factorio_arch=i386
+elif test "$CARCH" == x86_64; then
+ __factorio_arch=x64
+fi
+_gamepkg=factorio_alpha_${__factorio_arch}_$pkgver.tar.gz
+_pkgpaths_tries=("$startdir"
+ "$HOME/Downloads")
+
+build() {
+ msg "You need a full copy of this game in order to install it"
+
+ # look for game tarball
+ for pkgpath_try in "${_pkgpaths_tries[@]}" ; do
+ msg "Searching for ${_gamepkg} in dir: \"${pkgpath_try}\""
+ if [[ -f "${pkgpath_try}/${_gamepkg}" ]]; then
+ pkgpath=${pkgpath_try}
+ break
+ fi
+ done
+
+ # not found: ask for path to game tarball
+ if [[ ! -f "${pkgpath}/${_gamepkg}" ]]; then
+ error "Game package not found, please type absolute path to ${_gamepkg} (/home/joe):"
+ read pkgpath
+ if [[ ! -f "${pkgpath}/${_gamepkg}" ]]; then
+ error "Unable to find game package."
+ return 1
+ fi
+ fi
+
+ # unpack game tarball
+ msg "Found game package, unpacking..."
+ tar xzf "${pkgpath}/${_gamepkg}" -C "${srcdir}"
+}
+
+# no modifications needed, the executable looks for:
+# - data in /usr/share/factorio
+# - config in ~/.factorio
+
+package() {
+ cd "$srcdir/factorio"
+
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/share/factorio"
+ install -d "${pkgdir}/usr/share/licenses/factorio"
+
+ install -m755 "bin/${__factorio_arch}/factorio" "$pkgdir/usr/bin/factorio"
+ cp -r data/* "$pkgdir/usr/share/factorio"
+ install -m644 "${srcdir}/factorio.desktop" "${pkgdir}/usr/share/applications/factorio.desktop"
+ install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/factorio/LICENSE"
+}
diff --git a/factorio.desktop b/factorio.desktop
new file mode 100644
index 000000000000..f10d8cb14640
--- /dev/null
+++ b/factorio.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Factorio
+GenericName=Factorio
+Comment=A 2D game about building and maintaining factories.
+Exec=factorio
+Icon=/usr/share/factorio/core/graphics/factorio.png
+Terminal=false
+Type=Application
+Categories=Game;