summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMickaël Thomas2017-05-26 17:27:02 +0200
committerMickaël Thomas2017-05-26 17:27:02 +0200
commit1009a4e54f93b9fe8100e7fe2383478eef73b843 (patch)
treef4f6545d96531ce4b83c59bb269081844f058492
parent1fe18b977e6733f79737f9aa8896e295e366d934 (diff)
downloadaur-1009a4e54f93b9fe8100e7fe2383478eef73b843.tar.gz
Update to 0.15.14
Added -r flag to all read calls in PKGBUILD (thanks qdbp)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efd03f8241e1..66c43cec832d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 23 17:36:45 UTC 2017
+# Fri May 26 15:26:57 UTC 2017
pkgbase = factorio-experimental
pkgdesc = A 2D game about building and maintaining factories (experimental branch)
- pkgver = 0.15.13
+ pkgver = 0.15.14
pkgrel = 1
url = http://www.factorio.com/
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = factorio-experimental
depends = libxrandr
depends = libxinerama
depends = mesa
- provides = factorio=0.15.13
+ provides = factorio=0.15.14
conflicts = factorio
conflicts = factorio-demo
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 9d5b8e8bc078..2f36ca2d1b33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sebastien Duthil <duthils@free.fr>
pkgname=factorio-experimental
-pkgver=0.15.13
+pkgver=0.15.14
pkgrel=1
pkgdesc="A 2D game about building and maintaining factories (experimental branch)"
arch=('x86_64')
@@ -37,7 +37,7 @@ build() {
while [[ ! -f "${pkgpath}/${_gamepkg}" ]]; do
error "Game package not found."
- read -p "Please provide the path to the directory containing ${_gamepkg} or leave blank to download the game using your Factorio credentials:" pkgpath
+ read -rp "Please provide the path to the directory containing ${_gamepkg} or leave blank to download the game using your Factorio credentials:" pkgpath
if [[ -z "$pkgpath" ]]; then
_download && pkgpath="$SRCDEST" || true
@@ -76,8 +76,8 @@ _download() {
local password
local file="${SRCDEST}/${_gamepkg}"
- read -p "Username or email: " login
- [[ -n $login ]] && read -sp "Password: " password ; echo
+ read -rp "Username or email: " login
+ [[ -n $login ]] && read -rsp "Password: " password ; echo
if [[ -n $login && -n $password ]]; then
msg "Logging in..."
@@ -127,7 +127,7 @@ _download() {
else
error "Login failed"
#echo "$output"
- read -p "Try again? (Y/n)"
+ read -rp "Try again? (Y/n)"
[[ $REPLY == n ]] && break
fi
else