summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2020-04-17 11:07:39 +0200
committerMagnus Boman2020-04-17 11:07:39 +0200
commit4ccc83c79458e7b81321f8e4e725aebd9062e1e3 (patch)
tree8485e86deaaa93409938f9903fa41c68daf6506c
parented3f5ce2a3e01d0d6420f3251b96ee2ca7ecb5f2 (diff)
downloadaur-4ccc83c79458e7b81321f8e4e725aebd9062e1e3.tar.gz
Update to 7.6.8-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 24 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb2d73895744..5d8abd698fb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = fahcontrol
- pkgdesc = A Graphical User Interface (GUI)for Folding@Home
- pkgver = 7.5.1
+ pkgdesc = Graphical monitor and control utility for the Folding@home client
+ pkgver = 7.6.8.1
pkgrel = 1
- url = http://folding.stanford.edu/English/HomePage
- arch = x86_64
+ url = https://foldingathome.org
+ arch = any
license = GPL3
- depends = gtk2
depends = python2
depends = pygtk
- depends = glib2
- depends = pango
- options = !docs
- options = !libtool
- source = https://download.foldingathome.org/releases/public/release/fahcontrol/debian-stable-64bit/v7.5/fahcontrol_7.5.1-1_all.deb
- md5sums = 74cb2eae8654b254783aca4702dc702d
+ optdepends = fahviewer: 3D simulation viewer
+ source = https://download.foldingathome.org/releases/public/release/fahcontrol/debian-stable-64bit/v7.6/fahcontrol_7.6.8-1_all.deb
+ md5sums = f893e0f42de97b561b59b418b397502d
pkgname = fahcontrol
diff --git a/PKGBUILD b/PKGBUILD
index f1bca27c2fa9..d4a6456d0e90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,29 @@
+# Maintainer: katt <magunasu.b97@gmail.com>
+
pkgname=fahcontrol
-pkgver=7.5.1
+_pkgver=7.6.8-1
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='A Graphical User Interface (GUI)for Folding@Home'
-url="http://folding.stanford.edu/English/HomePage"
-arch=('x86_64')
+pkgdesc='Graphical monitor and control utility for the Folding@home client'
+url='https://foldingathome.org'
+arch=('any')
license=('GPL3')
-depends=('gtk2' 'python2' 'pygtk' 'glib2' 'pango')
-options=('!docs' '!libtool')
-source=(https://download.foldingathome.org/releases/public/release/fahcontrol/debian-stable-64bit/v7.5/fahcontrol_7.5.1-1_all.deb)
-md5sums=('74cb2eae8654b254783aca4702dc702d')
-
-# Moronic server
-DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
+depends=('python2' 'pygtk')
+optdepends=('fahviewer: 3D simulation viewer')
+source=("https://download.foldingathome.org/releases/public/release/${pkgname}/debian-stable-64bit/v${_pkgver:0:3}/${pkgname}_${_pkgver}_all.deb")
+md5sums=('f893e0f42de97b561b59b418b397502d')
-package() {
- cd ${srcdir}
+prepare() {
tar -xf data.tar.xz
-# python2 fixes
- cd ${srcdir}/usr/bin/
- for _file in $(find . -name 'FAHControl' -print); do
+ # python2 fixes
+ for _file in $(find "${srcdir}/usr/bin/" -name 'FAHControl' -print); do
sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' "${_file}"
sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' "${_file}"
- done
+ done
+}
- cd ${srcdir}
+package() {
install -dm755 ${pkgdir}/usr/lib/python2.7/site-packages/fah
cp -R ${srcdir}/usr/lib/python2.7/dist-packages/fah ${pkgdir}/usr/lib/python2.7/site-packages/
install -D -m0755 ${srcdir}/usr/bin/FAHControl ${pkgdir}/usr/bin/FAHControl